Case mx 135 problems!!!! - The Combine Forum
Register Home Forum Active Topics Gallery Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools
Old 12-22-2008, 08:27 PM   #1 (permalink)
Senior Member
 
tkfarms's Avatar
 
Join Date: Aug 2008
Location: HP Alberta
Posts: 464
Default Case mx 135 problems!!!!

Hi.... We are having some problems with our mx tractor lately. Was using the hay processer to grind hay for the cows and the pto would stop... I would lose all hydralics... and no transmission...( no movement) The only way to fix it is to shut the tractor off wait a few seconds and start it up again. We have had to use the 7120 on the processor but there isnt enough room for both tractors in the shop and it is bitterly cold out there now. If anyone has any ideas on the problem, that would be great!
tkfarms is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-22-2008, 10:58 PM   #2 (permalink)
Senior Member
 
Join Date: Nov 2007
Posts: 534
Default Re: Case mx 135 problems!!!!

Have had similar failures. It was the hyd pump one time and another it was the hyd pump compensator. You need to do some hyd tests.
steigerman is offline   Reply With Quote Quick reply to this message
Old 12-23-2008, 08:10 AM   #3 (permalink)
Senior Member
 
farmer79's Avatar
 
Join Date: Sep 2008
Posts: 158
Default Re: Case mx 135 problems!!!!

Had the exact same thing happen to my mx210 a copule of years back. I would loose pto, hyd, and couldnt change gears. My screen that displays the gears on the corner post would disappear. They call it a terminator. There is two of them on a tractor, one probally under the hood and one behind the cab. On the 210 I changed the one just above the starter and fixed it luckily. The one behind the cab is among all the computers on the back of the cab. Mine was a black box 2"x2"
It "terminates" the end of the computer wiring harness that lets all the computers communicate with each other. Cost me $40-50. make sure you get the newest ones. Dealer told me at that time they had changed them 230 times due to failures!!! Let me know if this helps.
farmer79 is offline   Reply With Quote Quick reply to this message
Old 12-23-2008, 09:59 AM   #4 (permalink)
Senior Member
 
Join Date: Nov 2007
Posts: 534
Default Re: Case mx 135 problems!!!!

MX 135 is not a Magnum like a MX210. MX 135s do not use terminators and the steering and hydraulics are all mechanical meaning electronics are not involved. When terminators fail Magnums and STX will have communication error codes and controllers wil go offline. There is also a splined shaft which runs the pto and hyd pump that can fail, there is an updated version available, however splines would not likely re-engage after slipping.
steigerman is offline   Reply With Quote Quick reply to this message
Old 12-23-2008, 05:22 PM   #5 (permalink)
Member
 
Join Date: Jul 2006
Posts: 73
Default Re: Case mx 135 problems!!!!

hi.. i had a 135.. bought it used. worked good for a month or 2. then all heck broke loose .2 transmission jobs that cost 1000$$$.dealer couldn't figure why it was breaking,, would totally lock up. broken gears and splines and caseings to know end.. real ugly to buy all that jewellry inside.. traded it on a mtx 110 MCcormick. so far so good.
headacker is offline   Reply With Quote Quick reply to this message
Old 12-23-2008, 05:31 PM   #6 (permalink)
Senior Member
 
tkfarms's Avatar
 
Join Date: Aug 2008
Location: HP Alberta
Posts: 464
Default Re: Case mx 135 problems!!!!

this tractor has been really good for us... bought it with 7000 hours on it. It was an emergency buy because some bearings in the clutch let loose in our 2290. Only thing we had to have done was a new soleniod for the forward, and also one for the pto!
tkfarms is offline   Reply With Quote Quick reply to this message
Old 12-24-2008, 12:10 AM   #7 (permalink)
Senior Member
 
tkfarms's Avatar
 
Join Date: Aug 2008
Location: HP Alberta
Posts: 464
Default Re: Case mx 135 problems!!!!

Hey Guys...thanks for the input. Farmer79 that is the same thing that happens... but I can change gears... it just wont move. The only fix is to shut the tractor off and restart it again.. and problem solved. It did it once when we had it outside a few weeks ago and we started it, otherwise it was doing it only when we used the pto!!
tkfarms is offline   Reply With Quote Quick reply to this message
Old 01-07-2014, 12:53 PM   #8 (permalink)
Junior Member
 
Join Date: Jan 2014
Posts: 3
Default

re mx 135 . having total hydraulic failure .used to be able to restart and would work again but now totally stopped . anyone know what to do to fix problem .
horseshoes is offline   Reply With Quote Quick reply to this message
Old 01-07-2014, 02:22 PM   #9 (permalink)
Senior Member
 
Join Date: Nov 2011
Posts: 1,784
Default

sounds like to me your hydrlic pump dose your loader still work if not your looking at a pump
mark 1056 is offline   Reply With Quote Quick reply to this message
Old 01-08-2014, 09:05 AM   #10 (permalink)
Junior Member
 
Join Date: Jan 2014
Posts: 3
Default

no everything quits including steering
horseshoes is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the The Combine Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 08:13 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.6.0