Rotor trouble 2388 - The Combine Forum
LinkBack Thread Tools
post #1 of 1 (permalink) Old 07-31-2012, 07:31 AM Thread Starter
Senior Member
blanchfarm's Avatar
Join Date: Sep 2008
Location: Clifton Queensland Australia
Posts: 1,101
Mentioned: 0 Post(s)
Quoted: 11 Post(s)
Rotor trouble 2388

hey guys
Have a problem with my 2388 i just noticed it a while ago and just getting around to fixing it.
what is happening is the hub of the rotor the part that has the big spring in it is starting to wear on the main drive belt the triple V belt i am just wanting to know if you guys have any idea what is happening.

i noticed it last harvest and replaced the engine mounts thinking it was old mounts and the engine was getting closer to the rotor. but that didn't work and now i am wondering if the rotor gearbox is coming back i started pulling it apart today but wont get back to it for a few days now.

Any help or suggestions would be great.

Thanks Roger
blanchfarm is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the The Combine Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome