J&M 1521 cart auger problems - The Combine Forum
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 07-17-2018, 09:55 AM Thread Starter
Senior Member
 
Join Date: Jan 2009
Location: NW Manitoba
Posts: 215
Mentioned: 0 Post(s)
Quoted: 38 Post(s)
J&M 1521 cart auger problems

Has anyone had problems with the auger u-joint setup on these carts? I currently have an 1150 that has a straight auger and its been trouble free. Looking at upgrading to a used 1521 but I see they have a u-joint in the auger hinge area because the auger runs at an angle. Dealer told me auger and drive was replaced last winter on this unit. Sounds like this was a problem J&M was aware of and covered the cost of the repair. I'm not sure if the parts were updated to a newer design to solve the problem. Want to hear of isssues others have had before I consider this unit. I see the newer 1522 carts have eliminated the u-joint and have a solid auger similar to my 1150.

bmich is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Combine Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome