Case IH 9170 steiger Trans issue - The Combine Forum
LinkBack Thread Tools
post #1 of 6 (permalink) Unread 10-19-2019, 08:48 PM Thread Starter
Member
 
Join Date: Nov 2017
Location: Kansas
Posts: 94
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
Barn
Case IH 9170 steiger Trans issue

We have a 9170 that has developed an issue as of late, it has the FUJI 12 spd power shift transmission. It will shift into all the gears fine and doesn't make any noise, however we just started pushing silage and with the dozer on pushing it goes fine in 1-3 but once you shift to 4th it will just stop and doesn't have the violent gear change we are used to feeling. So my question is do you think it's clutch related or larger a transmission problem?

jegster10 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Unread 10-19-2019, 11:55 PM
Senior Member
 
Join Date: Jan 2015
Location: Bowdon ND
Posts: 166
Mentioned: 0 Post(s)
Quoted: 30 Post(s)
My 9150 did that in 7th I think it was.. From the way it sounds you may want to do a few different checks, Mine would shift fine, ran down the road great, but the second you'd put it under a load even just pushing the brakes in any gear higher it would stop. If you are having these problems you have clutch problems. If you can't do the tranny job yourself save the trouble and call Big Tractor Parts in Holly MN, a new tranny from them is 16K exchanged. And they will give you some good tips on how to get it out.. CIH dealers will get you just as much in labor as BTP will for a whole new tranny

RC Ranch is offline  
post #3 of 6 (permalink) Unread 10-20-2019, 03:52 AM
Junior Member
 
Join Date: Sep 2017
Location: Saskatchewan
Posts: 12
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
How are your batteries and connections? Try cleaning your posts and cable ends, charging them up and see if it does the same thing.
Cosmo is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Unread 10-20-2019, 11:03 PM
Member
 
Dialed In's Avatar
 
Join Date: Aug 2011
Location: North Central Montana
Posts: 96
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Does the shift display show dashes, does it show you are in fourth, or is there a code like E:60? Is your speed display showing the correct mph or is it a little erratic?
Dialed In is offline  
post #5 of 6 (permalink) Unread Yesterday, 11:27 PM Thread Starter
Member
 
Join Date: Nov 2017
Location: Kansas
Posts: 94
Mentioned: 0 Post(s)
Quoted: 14 Post(s)
Barn
No codes, no errors, electronics are good. Tranny is basically shot, no clutches left so it looks like it’s reman time since we would have just as much in labor trying to rebuild it and still not have a warranty or proper rebuild.
jegster10 is offline  
post #6 of 6 (permalink) Unread Today, 10:08 AM
Senior Member
 
Grainline's Avatar
 
Join Date: Dec 2012
Location: Central alberta
Posts: 436
Mentioned: 0 Post(s)
Quoted: 50 Post(s)
It's about 1/2 the price to have it rebuilt at a local shop then replaced at least up here it was. I did one last winter for a customer all new bearings and replaced clutches that need to be done. There a simple trans to rebuild. Just heavy and you have to have a good puller set to get bearings off.
Grainline is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Combine Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome