JD 7920 controllers - The Combine Forum
 1Likes
  • 1 Post By Carlproulx
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 10-21-2019, 06:36 AM Thread Starter
Senior Member
 
Join Date: Jun 2011
Location: Kangaroo Island, SA, Australia
Posts: 521
Mentioned: 0 Post(s)
Quoted: 16 Post(s)
JD 7920 controllers

Had a couple codes come up on start up the other day. Switched it off and they didn't come back but today they stayed on. Engine starts but that's about it armrest and shift stick all inoperable. Cycled key on and off probably 2 dozen times and it eventually cleared. Local dealer not interested. The codes are-
Pti 2005.09
Icu 2005.09
Hcu 2005.09
Scu 2005.09
Sfa 2005.09
ECU 2005.09
ECU 1568.02

Many thanks. Middle of hay cutting

WillStanton is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-21-2019, 09:51 AM
Junior Member
 
Carlproulx's Avatar
 
Join Date: Aug 2015
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Check the harness from the floor to the armrest inside the loom there is a splice for the can-bus the green and yellow wire some time a wire broke of and the armrest controller doesnt communicate on the can-bus

torriem likes this.
Carlproulx is offline  
post #3 of 5 (permalink) Old 10-21-2019, 05:46 PM Thread Starter
Senior Member
 
Join Date: Jun 2011
Location: Kangaroo Island, SA, Australia
Posts: 521
Mentioned: 0 Post(s)
Quoted: 16 Post(s)
Thanks! Will do
WillStanton is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 10-22-2019, 08:02 PM Thread Starter
Senior Member
 
Join Date: Jun 2011
Location: Kangaroo Island, SA, Australia
Posts: 521
Mentioned: 0 Post(s)
Quoted: 16 Post(s)
I'm starting to think it is the Armrest controller. Do these go bad? Can't see any issues with wiring or components
WillStanton is offline  
post #5 of 5 (permalink) Old 10-22-2019, 08:53 PM
Senior Member
 
7miles's Avatar
 
Join Date: Dec 2014
Location: Gravelbourg,SK
Posts: 124
Mentioned: 0 Post(s)
Quoted: 33 Post(s)
Yes, just had to change our arm rest controller last year on our 7920 and 9430.. Happens often enough as our dealership had both of them in stock.
7miles is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Combine Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome