Flexicoil control problem - The Combine Forum
 3Likes
  • 1 Post By Last gen farmer
  • 2 Post By Thebaleguy
 
LinkBack Thread Tools
post #1 of 10 (permalink) Old 05-16-2010, 09:44 AM Thread Starter
Member
 
Join Date: Mar 2010
Posts: 54
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Flexicoil control problem

I have a 67xl flexi sprayer with a sp65s controller. My auto rate controller has gone on the fritz. In manual mode I can turn the pressure down but not up. In auto mode the same thing happens. Voltage is good at the 3 way valve when the + button is pressed. Any ideas?

tigety is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 05-17-2010, 10:55 PM
Senior Member
 
Join Date: Sep 2007
Location: Strongfield, Sask, Canada
Posts: 213
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
Re: Flexicoil control problem

I would bet your valve control motor is going. We have one acting up as well and will likely put a new motor on in the next few days ( we keep one of them as well as pressure and flow sensors on hand).

ry0972 is offline  
post #3 of 10 (permalink) Old 05-18-2010, 09:29 PM Thread Starter
Member
 
Join Date: Mar 2010
Posts: 54
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Re: Flexicoil control problem

Ry0972-do you use a motor from flexicoil or have you found who makes this for flexi? I think the stealership quoted me around $1200 for the motor/valve assembly. TIA
tigety is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 05-19-2010, 11:58 PM
Senior Member
 
Join Date: Sep 2007
Location: Strongfield, Sask, Canada
Posts: 213
Mentioned: 0 Post(s)
Quoted: 8 Post(s)
Re: Flexicoil control problem

We have/had a spare OEM motor on hand. changed it out and ours is still slow to adjust pressure (sometimes wont adjust till I do it a bit manually) we lubed the stem that comes out of the valve and that seemed to help. It will increase the pressure most of the time but decrease is rare ( as it has to fight against the water pressure to close valve) unless it tries in some rough stuff then it usually works. I think if I get time I will pull the valve apart and clean/check/change it, When they say 12 inch pounds on the valve bolts they mean 12 MAX.
Tried our spare monitor with same results.

When we bought the last two motors they were $500 each and high $600 with the valve. When/if you just buy a motor get the drive coupler as well !!! They are usually rusted on so you have to pry the plastic part off and heat the steel collar to get it off (did two today without damage) Loaded it up with Anti-seize when it went back together.
I wish the sprayers were plumbed with the band clamp style fittings instead of threaded ! Depending on year and options it can be fun getting a broken/leaking fitting out/fixed.
ry0972 is offline  
post #5 of 10 (permalink) Old 05-20-2010, 12:16 AM
460
Senior Member
 
Join Date: Sep 2007
Location: Moose Jaw, Sask.
Posts: 1,786
Mentioned: 0 Post(s)
Quoted: 193 Post(s)
Re: Flexicoil control problem

You can buy just the motor. You don't need the valve. Don't throw that motor away, they can be fixed easily by an electronics tech. The motor should only be 4-500can.
460 is offline  
post #6 of 10 (permalink) Old 06-13-2019, 12:46 AM
Junior Member
 
Join Date: Apr 2018
Posts: 2
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
came across this old thread as I am having a similar issue with the sp655 controller on my old model 62 sprayer . I believe my problem lies in the controller, just looking for any additional insights anyone may have before replacing it, if I can find one.

Having trouble with controller operating the 3 way valve.
- On startup and for about 1hr of operation, all was good. Then auto rate controller closed valve and will not open it.
- Removed motor from valve and finished field without auto rate.
- When I hooked motor back up next day, seemed to be operating properly again. Motor turns both ways, a little slower one way. (About 8 seconds to go one way, 6 the other).
- I decided to open up controller to see if anything was visibly lose or damaged. All looked ok. Cleaned it up and put it back together. When I hooked it back up to controller, was way slower going one way. Probably 10-12 seconds. A few cycles through it and it was worse. To the point it was no longer operable.
- When I connected the monitor bypass (grey thingy), it would quickly turn the motor - I didn’t have it on the valve but I assume this is to turn it to full open position. When I then connected monitor again, it would turn it quickly one way but pretty much dead the other. So thinking the problem is within the monitor / controller unit?
- had the motor checked at an electronic shop first time this happened so don’t think it is the motor. It tested fine.
Thebaleguy is offline  
post #7 of 10 (permalink) Old Yesterday, 02:23 AM
Senior Member
 
Join Date: Aug 2016
Posts: 280
Mentioned: 0 Post(s)
Quoted: 24 Post(s)
I had a prototype Val air sprayer with a flexicoil rate controller in it. Was always giving problems so I changed it to a spraymate system with a gps type signal for speed. Super accurate system and very easy to plumb in to the liquid and electrical. Have a raven not and it’s a pos in comparison. Think I paid 1400$ for the complete kit 15 years ago and remember seeing it recently for not much more.
Transaxial likes this.
Last gen farmer is offline  
post #8 of 10 (permalink) Old Yesterday, 03:33 PM
Senior Member
 
lanwickum's Avatar
 
Join Date: Jul 2011
Location: North Central Montana
Posts: 1,816
Mentioned: 0 Post(s)
Quoted: 310 Post(s)
I thought micro trak was out of business? I may be able to bring a sprayer back to life now. Affordably.... Looked up spraymate and was rather amazed to see what I found. They are a good simple rate control system.
lanwickum is offline  
post #9 of 10 (permalink) Old Today, 02:23 PM
Junior Member
 
Join Date: Apr 2018
Posts: 2
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
I did figure out my problem. I was wrong about it being the monitor. Had rewired it to bypass the monitor so I could at least adjust rate from the cab, hooked that up and did the same **** thing! Took cover off motor again and played around with it. Tapped one of the switches that limits its rotation and voila, back in business...
torriem and Transaxial like this.
Thebaleguy is offline  
post #10 of 10 (permalink) Old Today, 05:35 PM
Senior Member
 
Join Date: Jun 2012
Location: east central Alberta
Posts: 1,201
Mentioned: 0 Post(s)
Quoted: 244 Post(s)
Quote:
Originally Posted by Thebaleguy View Post
I did figure out my problem. I was wrong about it being the monitor. Had rewired it to bypass the monitor so I could at least adjust rate from the cab, hooked that up and did the same **** thing! Took cover off motor again and played around with it. Tapped one of the switches that limits its rotation and voila, back in business...
As this thread was progressing I thought of the limit switches inside. Kind of cheezy little things that see a lot of use. Glad you found it! Similar to limit switches on old three ton two speed axles that were the usual problem with them quitting. IIRC you could buy the little circuit board with the new contacts and get you going again.

Transaxial is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Combine Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in













Similar Threads
Thread Thread Starter Forum Replies Last Post
GS-2 rate control for flexicoil sprayer deerty Sprayers / Chemicals / Fertilizer 8 05-24-2016 10:07 PM
8100 control hydraulics 3rd party control box grantosw Tractors 1 12-29-2011 10:32 PM
1330 Flexicoil problem pj9510 Planting & Tillage 3 03-31-2010 07:08 AM
auto height control or auto spray control farmer Sprayers / Chemicals / Fertilizer 8 02-13-2009 09:11 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome