DIY AutoSteer with AgOpenGPS - Page 77 - The Combine Forum
 1214Likes
 
LinkBack Thread Tools
post #761 of 2024 (permalink) Old 04-01-2018, 12:08 PM Thread Starter
Senior Member
 
Join Date: Aug 2012
Location: Vermilion Alberta Canada
Posts: 5,740
Mentioned: 19 Post(s)
Quoted: 2503 Post(s)
Quote:
Originally Posted by BrianTee View Post
Bad news, i picked up my mail this morning and a certified letter was from SAE. In it was a cease and desist letter outlining why standards need to be purchased and registered for any claim of use of ISOBUS. That also the project be removed from github.

I must comply.
April Fools! Hee Hee.

(With time zones and different cultures all around the world, probably not as effective)

BrianTee is offline  
Sponsored Links
Advertisement
 
post #762 of 2024 (permalink) Old 04-01-2018, 01:42 PM
Senior Member
 
wvca's Avatar
 
Join Date: Nov 2014
Location: Yorkton, Sk, Canada
Posts: 457
Mentioned: 0 Post(s)
Quoted: 110 Post(s)
Barn
got me, forgot it was april 1st, lol

BrianTee and WTalen like this.

regards, warren
wvca is offline  
post #763 of 2024 (permalink) Old 04-01-2018, 04:37 PM
Senior Member
 
Join Date: Mar 2018
Location: South Bavaria
Posts: 165
Mentioned: 8 Post(s)
Quoted: 70 Post(s)
Quote:
April Fools! Hee Hee.
OMG i failed completely

By the way Daniel Feiter has completed the translation of the Danfoss valve section at the Wiki
BrianTee and CQuick like this.
Weder is offline  
Sponsored Links
Advertisement
 
post #764 of 2024 (permalink) Old 04-01-2018, 05:45 PM Thread Starter
Senior Member
 
Join Date: Aug 2012
Location: Vermilion Alberta Canada
Posts: 5,740
Mentioned: 19 Post(s)
Quoted: 2503 Post(s)
Still some work on the languages other then default to be done, but a lot better. They were really messed up.

On here: https://github.com/farmerbriantee/AgOpenGPS

Removed the Dev Github one. "There can be only one".

2.6 April Fools
* 12 Sections
* Uturn has repeatable multi swath loops, Dew Loops
* Minor fixes
* Cross track error on contour button - averages 4 seconds of summed XTE
* You turn relay out steer and rate ports
* Fix workswitch, decode at serial recv
* Languages were a mess, huge mess, fixed a lot of it
* Added Lo Hi bytes for relays which now takes 2 bytes
* Rate module has both, steer module has only first 8 sections
* Rate module PGN's reflect extra section byte
* Steer module serial decoders match what is sent
BrianTee is offline  
post #765 of 2024 (permalink) Old 04-02-2018, 06:15 AM
Senior Member
 
Join Date: Mar 2018
Location: South Bavaria
Posts: 165
Mentioned: 8 Post(s)
Quoted: 70 Post(s)
Ah.. I see new secret codename
Quote:
2.6 April Fools
......ouch

Have tested the Switches but only Workswitch is now working, the Autosteerswitch still did not work?
UTurnrelays works now fine at both Ports

Made an Update to the AutoSteer_DanfossPWM Sketch too.
Added uTurn relay output, reset Fixvalues
But as long as the Autosteer Switch isn't recognized by AOG the Steering Wheel Encoder won't work fully.

BTW: Hompage-Link to Github must be updated
Attached Files
File Type: zip AutoSteer_DanfossPWM.zip (13.6 KB, 26 views)
Weder is offline  
post #766 of 2024 (permalink) Old 04-02-2018, 06:34 AM
Senior Member
 
Join Date: Jan 2018
Location: P.E.I. Canada
Posts: 211
Mentioned: 2 Post(s)
Quoted: 84 Post(s)
The auto steer switch is working for me with version 2.5
WTalen is offline  
post #767 of 2024 (permalink) Old 04-02-2018, 09:23 AM
Senior Member
 
Join Date: Mar 2018
Location: South Bavaria
Posts: 165
Mentioned: 8 Post(s)
Quoted: 70 Post(s)
Ok, hmm an i can see both lines in the Sourcecode
Quote:
mc.workSwitchValue = mc.steerSwitchValue & 1;
mc.steerSwitchValue = mc.steerSwitchValue & 2;
Will try again later

.........
Later: Hmm nothing, doesn't do anything?

Last edited by Weder; 04-02-2018 at 04:16 PM. Reason: Retry later
Weder is offline  
post #768 of 2024 (permalink) Old 04-02-2018, 05:54 PM
Member
 
Join Date: Mar 2018
Location: Belgium
Posts: 87
Mentioned: 1 Post(s)
Quoted: 45 Post(s)
Quote:
Originally Posted by WTalen View Post
Did some field testing today. A little bit of tweaking to do with the PID settings and also You-turn settings. This is really exciting! It seems like a DGPS fix is working pretty good too. Still thinking about a pair of ReachRS' though.
I am very much interested in the details how you mounted that motor. It looks very handy! I would like to build autosteer in our New Holland TS90 and T6050 some time this summer.
kareldew is offline  
post #769 of 2024 (permalink) Old 04-02-2018, 06:56 PM Thread Starter
Senior Member
 
Join Date: Aug 2012
Location: Vermilion Alberta Canada
Posts: 5,740
Mentioned: 19 Post(s)
Quoted: 2503 Post(s)
The work switch turns the sections on manually - like a workswitch. Auto is disabled, but you can still hit the manual button on off.

The steer switch is only for the arduino to stop trying to turn the motor, it is sent back to AOG for magical reasons i do not know. Edit: Oh now i remember, i tagged it along with the workswitch since it was using 1 bit out of the 8 so i thought just throw it along for free. AOG still thinks its controlling the world - but its not.

Weder, what should we do with multiple versions of autosteer ino's? just keep adding directories to AgOpenGPS on github and put them all in one place? Links to your github?

There isn't anything April fools about the 2.6 update - its all business!! Went to another version because it now saves 12 sections and the files have more settings and features. Rather then cause exception faults, just force new ones.

What do you think about coming to settings after loading a vehicle? It forces error checking and helps you see what you have loaded.

Yes, the auto UTurn is working really well - considering there are a thousand ways it potentially can lock the whole computer up, it behaves quite well. Turning the UTurn button off - on again cancels and disables the dew loop. Maybe that is too harsh?

And this might piss some people off, but minimum display resolution will be 1400 x 800 lines going forward - more so 900 minimum. considering all the stuff it can now do, and will do, recommended size will be a Full HD display. My tractor tablet has 2160 x 1440 and it looks ridiculous having a huge mapping area and crammed tab area. Was walking around Best Buy today and most tablets are at least 8 to 900 lines - and they are only 200 bucks.

The new size for comparison on an hd screen. 1920 x 1080 at minimum functional size.
Attached Images
File Type: png 2018-04-02.png (452.6 KB, 35 views)

Last edited by BrianTee; 04-02-2018 at 07:00 PM.
BrianTee is offline  
post #770 of 2024 (permalink) Old 04-02-2018, 07:02 PM Thread Starter
Senior Member
 
Join Date: Aug 2012
Location: Vermilion Alberta Canada
Posts: 5,740
Mentioned: 19 Post(s)
Quoted: 2503 Post(s)
Quote:
Originally Posted by Weder View Post
Ok, hmm an i can see both lines in the Sourcecode

Will try again later

.........
Later: Hmm nothing, doesn't do anything?
Silly question and i know you did it, but did you enable the workswitch in settings?

BrianTee is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Combine Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome