AgOpenGPS - adding rate control - Page 20 - The Combine Forum
 97Likes
Reply
 
LinkBack Thread Tools
post #191 of 199 (permalink) Old 04-19-2019, 09:27 PM
Senior Member
 
Join Date: Aug 2012
Location: Vermilion Alberta Canada
Posts: 5,345
Mentioned: 5 Post(s)
Quoted: 2342 Post(s)
1. The display updates every second on the tab, but the data comes in at 5 or 10 hz depending on gps rate. Data isn't lost, its just that its impossible to read 5 numbers per second, but all the calculations are done at full speed.


2. I think the sim is calculating distance wrong, I must have messed something up. Does it work correctly with actual GPS? Distance/speed correctly.


3. The section on the left sees unapplied area straight ahead of it like a box in front the section - so it will turn on. The math is way beyond anyone so far to do curved lookahead.

BrianTee is offline  
Sponsored Links
Advertisement
 
post #192 of 199 (permalink) Old 04-20-2019, 10:05 AM
Junior Member
 
kaanakgser's Avatar
 
Join Date: Mar 2019
Posts: 24
Mentioned: 0 Post(s)
Quoted: 9 Post(s)
Quote:
Originally Posted by BrianTee View Post
1. The display updates every second on the tab, but the data comes in at 5 or 10 hz depending on gps rate. Data isn't lost, its just that its impossible to read 5 numbers per second, but all the calculations are done at full speed.


2. I think the sim is calculating distance wrong, I must have messed something up. Does it work correctly with actual GPS? Distance/speed correctly.


3. The section on the left sees unapplied area straight ahead of it like a box in front the section - so it will turn on. The math is way beyond anyone so far to do curved lookahead.
Thank you for your reply, regards.

1-) The pressure motor should stop at the sample 300 because it senses the flow information late, it falls to 250 or increases to 350.
2-) I will do a speed test with GPS.
3-) I think something like this will work hard.

Attached Images
File Type: png Adsız.png (89.6 KB, 126 views)

Last edited by kaanakgser; 04-20-2019 at 05:06 PM.
kaanakgser is offline  
post #193 of 199 (permalink) Old 04-20-2019, 11:57 AM
Senior Member
 
Join Date: Aug 2012
Location: Vermilion Alberta Canada
Posts: 5,345
Mentioned: 5 Post(s)
Quoted: 2342 Post(s)
1)Wouldn't that be part of the arduino code then? The data coming back from the flow module is only for display purposes.

3) Pretty sure that won't work around corners either.
BrianTee is offline  
Sponsored Links
Advertisement
 
post #194 of 199 (permalink) Old 04-20-2019, 05:01 PM
Junior Member
 
kaanakgser's Avatar
 
Join Date: Mar 2019
Posts: 24
Mentioned: 0 Post(s)
Quoted: 9 Post(s)
Quote:
Originally Posted by BrianTee View Post
1)Wouldn't that be part of the arduino code then? The data coming back from the flow module is only for display purposes.

3) Pretty sure that won't work around corners either.

You're very right, so let me check the delay and the PID system in the ino code. my pressure motor is moving 1 mm in 1 turn and should be at 30 rpm and I should raise it to 60 rpm.
Regards, Thanks.
kaanakgser is offline  
post #195 of 199 (permalink) Old 04-22-2019, 03:54 PM
Senior Member
 
Join Date: Jan 2018
Location: near Stuttgart, Germany
Posts: 174
Mentioned: 0 Post(s)
Quoted: 67 Post(s)
Quote:
Originally Posted by kaanakgser View Post
Thank you for your reply, regards.

1-) The pressure motor should stop at the sample 300 because it senses the flow information late, it falls to 250 or increases to 350.
2-) I will do a speed test with GPS.
3-) I think something like this will work hard.
Hi kaanakgser,

You can increase the min unapplied to 100 pixel, so AOG starts spraying later when driving in the field from a diagonal headland, like in you middle image. I use 80, the sprayer starts spraying if the gap between two applied areas gets larger than 50cm.

I spray without RTK, so I can't use the exact boundarys from government system, they are about 1m wrong.
When starting a new field I change the outer section from 3m to 5m and spray the headland. In the field I spray with the correct settings, so the sections don't spray outside the field. Another option is to create everytime a new boundary for every field.

Greetings Matthias
MTZ8302 is offline  
post #196 of 199 (permalink) Old 04-22-2019, 08:34 PM
Junior Member
 
kaanakgser's Avatar
 
Join Date: Mar 2019
Posts: 24
Mentioned: 0 Post(s)
Quoted: 9 Post(s)
Quote:
Originally Posted by MTZ8302 View Post
Hi kaanakgser,

You can increase the min unapplied to 100 pixel, so AOG starts spraying later when driving in the field from a diagonal headland, like in you middle image. I use 80, the sprayer starts spraying if the gap between two applied areas gets larger than 50cm.

I spray without RTK, so I can't use the exact boundarys from government system, they are about 1m wrong.
When starting a new field I change the outer section from 3m to 5m and spray the headland. In the field I spray with the correct settings, so the sections don't spray outside the field. Another option is to create everytime a new boundary for every field.

Greetings Matthias
Thank you for the answer, Matthias.
I'm using neo7p which I share the video I don't use RTK. How do I set the Pixel? Do you use rate control? I'm using Arag's flowmeter, but no matter how much I've set with the PID settings, the pressure engine doesn't stop at the setpoint. For example, 300 LPMs should stop at 220 when they should stop and rise to 360. Sometimes it stands at 300 and then it still rises and falls. I'm using Weder's code.

Best regards.
kaanakgser is offline  
post #197 of 199 (permalink) Old 04-25-2019, 04:33 PM
Junior Member
 
kaanakgser's Avatar
 
Join Date: Mar 2019
Posts: 24
Mentioned: 0 Post(s)
Quoted: 9 Post(s)
Hello to everyone;
rate control test with 6 bar air. Arag's flowmeter misled me, the $ 5 flowmeter worked very well, very interesting. I made little changes in the rate ino codes, I thank everyone for their help and efforts.
Best regards.




Beerwiser, BrianTee and WTalen like this.
kaanakgser is offline  
post #198 of 199 (permalink) Old 05-11-2019, 08:12 PM
Junior Member
 
Join Date: Oct 2018
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I have set up section control using MTZ's ino. Is it possible to use more than 12 sections. Notes in the ino say 16 possible but AOG only supports 12. Am I missing something simple.

Thanks,
jwrogers is offline  
post #199 of 199 (permalink) Old Today, 07:34 AM
Junior Member
 
Join Date: May 2019
Location: Blenheim, New Zealand
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Hi all. I am in Marlborough, New Zealand growing wine grapes, roughly 500ha. I am doing some experimenting with AOG in a Fendt 209 vineyard tractor with a canopy sprayer. At the moment I've got section control working for the sprayer and next is to get the rate control working. My goal is to get rate control based off l/100m instead of l/ha. (this works better for our spray programs with blocks of varying row widths etc). Does anyone have an idea what the code would look like for l/100m rate control in AOG?

Cheers!
Murray
murrayfaber is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Combine Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome