EZ Pilot repair anyone? - The Combine Forum
 2Likes
  • 2 Post By Transaxial
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 11-07-2018, 08:03 AM Thread Starter
Senior Member
 
Join Date: Oct 2015
Location: Greenwater lake area Sask
Posts: 750
Mentioned: 0 Post(s)
Quoted: 184 Post(s)
EZ Pilot repair anyone?

Been intrigued by Brians ag open gps. That is something I hope to read up on this winter. Back to my question here. I have a Trimble 750 with EZ pilot and the EZ Pilot quit working. I swapped it out with another and all is fine. I replaced the cable and it fixed the failed one for about 350 acres then no signal again. Sam 200 error. I tried to get it repaired with no luck really. Buy a new one is all I get told. Anyone out there fix these?? Likely a simple fix for a $3900 part.

dookiller is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 11-07-2018, 11:35 AM
Senior Member
 
Join Date: Jun 2012
Location: east central Alberta
Posts: 1,177
Mentioned: 0 Post(s)
Quoted: 237 Post(s)
Quote:
Originally Posted by dookiller View Post
Been intrigued by Brians ag open gps. That is something I hope to read up on this winter. Back to my question here. I have a Trimble 750 with EZ pilot and the EZ Pilot quit working. I swapped it out with another and all is fine. I replaced the cable and it fixed the failed one for about 350 acres then no signal again. Sam 200 error. I tried to get it repaired with no luck really. Buy a new one is all I get told. Anyone out there fix these?? Likely a simple fix for a $3900 part.
I am not responding from specific knowledge of these units but simply from a point of view that if the next move is to buy a new one anyway, you might as well do some testing and experimenting with the old one. I am starting my thinking from the point that you say you changed the cable and the old one worked again for 350 ac. Does the original cable work again intermittently? is it just in the plug? male or female that when you change the cable it makes the connection by wiggling something? I know there can be a ton of wires in those cables but it could be just a continuity check on each wire. But if 2 different cables give you intermittent operation then maybe it is deeper into the unit but still just connections. The internet might help you find a new plug for a cable that could be changed. A job for a cold wintery day when you have time to sit down and really think it through. I find that I think better when combine is not waiting to go to the field!!! The incentive is you might find some little thing loose and save yourself $3900! Good luck

Let us know what you find.

BrianTee and radar like this.
Transaxial is offline  
post #3 of 3 (permalink) Old 11-07-2018, 06:14 PM
Junior Member
 
Join Date: Jan 2015
Location: S Alberta
Posts: 12
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Had a similar problem. I cleaned the battery connections and it solved my problem
Wade57 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Combine Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ez Guide Plus and Ez Steer to Ez Guide 250 9520deere Technology 2 04-07-2016 03:44 PM
Trimble EZ pilot? andyr Technology 16 08-10-2013 09:20 AM
FM 750 with EZ Pilot for M series macdon hondaman Technology 4 07-25-2012 09:13 AM
Trimble Ez-pilot JCB Fastrac SwathnOZ Technology 4 03-04-2012 10:22 AM
Trimble EZ-Pilot on a Sprayer okpanhandle Technology 2 01-27-2012 04:06 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome