U-Blox NEMA strings settings - The Combine Forum
 2Likes
  • 1 Post By m_elias
  • 1 Post By crash5291
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 08-25-2019, 04:45 AM Thread Starter
Member
 
Join Date: Jul 2018
Location: Lansdowne, Ontario
Posts: 55
Mentioned: 3 Post(s)
Quoted: 11 Post(s)
U-Blox NEMA strings settings

Hi all,

i have noticed an scratched my head over this problem for a while. While doing the boundary AOG seeming tracks great, but when working with the section on it paints the line in jumps that do not follow the course taken in relation the boundary.

i happened to notice tonight while watching one of Brian's latest video's his incoming GPS information was MUCH smoother then the output i get.

I have now changed the rate from 1 hz to 10 on the ublox M8p this helped.

now i would like to adjust the NEMA sets sent to the tablet to only send the ones i need and stop the rest as they are not required.

My options are attached in the image.

(steering not currently in use, just guidance)

Thoughts?
Cheers, Joe

Attached Images
File Type: png nema1.png (53.1 KB, 23 views)

Drive lots of little things, one day i will get to play with big toys.
crash5291 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-26-2019, 10:57 AM
Senior Member
 
Join Date: May 2011
Location: Manitoba
Posts: 369
Mentioned: 0 Post(s)
Quoted: 97 Post(s)
Disable all but GGA & VTG?
https://www.thecombineforum.com/foru...ml#post3354589

crash5291 likes this.
m_elias is offline  
post #3 of 6 (permalink) Old 08-26-2019, 03:50 PM Thread Starter
Member
 
Join Date: Jul 2018
Location: Lansdowne, Ontario
Posts: 55
Mentioned: 3 Post(s)
Quoted: 11 Post(s)
Thanks i had not seen that post yet!

Cheers,
Joe
BrianTee likes this.

Drive lots of little things, one day i will get to play with big toys.
crash5291 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 09-02-2019, 05:40 PM
Junior Member
 
Edu_Puixa's Avatar
 
Join Date: May 2019
Location: Latvia
Posts: 21
Mentioned: 1 Post(s)
Quoted: 9 Post(s)
When configuring U-Blox ZED F9P, do I have to change same settings on both units (base and rover) or only on rover side? I'm talking about Hz, baud rate and NMEA settings. And for GGA and VTG messages, do I select them from all satellites or some specific constellation? Default is same as in the first post by crash5291 - GNGGA and GNVTG. And what are last messages in each group that starts with dash ( _GGA, _VTG for example)?
Edu_Puixa is offline  
post #5 of 6 (permalink) Old 09-03-2019, 03:39 PM
Senior Member
 
Join Date: May 2011
Location: Manitoba
Posts: 369
Mentioned: 0 Post(s)
Quoted: 97 Post(s)
Quote:
Originally Posted by Edu_Puixa View Post
When configuring U-Blox ZED F9P, do I have to change same settings on both units (base and rover) or only on rover side? I'm talking about Hz, baud rate and NMEA settings. And for GGA and VTG messages, do I select them from all satellites or some specific constellation? Default is same as in the first post by crash5291 - GNGGA and GNVTG. And what are last messages in each group that starts with dash ( _GGA, _VTG for example)?
As I see it, the base and rover are performing different functions. The base is gathering satellite data to output correction data for the rover to use. The rover is applying this correction to it's satellite data to output accurate position data for your application/use. The only two main things common between them is the satellite constellations that they are tracking and the format of the correction data. The base has to track the same satellite constellations as the rover in order to output relevant correction data and the format of that correction data needs to be compatible with both.

Otherwise, the rest of the settings should be set according to the function they are performing.
Baud rate is a setting specific to a serial data link, the sender/receiver baud (and other settings) have to match and it has to be fast enough to keep up with the volume of data. Your base probably (but not necessarily) has a serial output for it's correction data to a radio or ntrip castor, those serial settings could be completely different than the rover's correction input serial port. Your base probably does not need to output any NMEA data but most likely your rover does. My Piski Multi base station only outputs it's RTCM (correction data) every second and I have it's solution frequency set to 10hz but I suspect it would only need to calculate it's own position at the same rate as the RTCM output. On my rover though, I want a minimum of 5hz.
m_elias is offline  
post #6 of 6 (permalink) Old 09-03-2019, 04:37 PM
Junior Member
 
Edu_Puixa's Avatar
 
Join Date: May 2019
Location: Latvia
Posts: 21
Mentioned: 1 Post(s)
Quoted: 9 Post(s)
Thanks m_elias, I'm thinking by the same line, but as both boards had these settings identical when I received them, I thought better to ask. I will change what is needed for rover and leave base as is for the moment. Later I will check what happens when I turn off NMEA sentences for base, cause constellations are set in different settings.

Maybe someone can chime in about different GGA and VTG sentences - need all of them, some of them or only one? I'm thinking that, if I use multiple constellations, then I need to use appropriate GGA and VTG sentences as well.
Edu_Puixa is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Combine Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome