The Combine Forum - View Single Post - DIY AutoSteer with AgOpenGPS
View Single Post
post #1764 of (permalink) Old 05-12-2019, 10:04 AM
Andreas Ortner
Senior Member
 
Join Date: Nov 2016
Location: Austria
Posts: 788
Mentioned: 3 Post(s)
Quoted: 320 Post(s)
Quote:
Originally Posted by lylevd View Post
Great work Brian and the crew! This is a wonderful project that the agricultural community has been needing for some time.
I set up an Arduino Leonardo with the basic auto steer code. I have set it up with the default pin out. Arduino and IB2 and a princess auto angle sensor with no other components sitting stationary on my desk for testing. I can connect to my com port with putty and can see the five segments of data returned. -11.12,0.00,9999,9999,1 . Even a Arduino with nothing hooked up will spit out data on the com port. 9.76,0.00,9999,9999,1 Agopen connects to the com port but does not seem to see the data. It says "Oops NC". Have i completely overlooked something? Agopen connects just fine to the GPS com port and returns GPS coordinates. Files, schematics, etc are all from the latest AgOpenGPS-master.zip on github.
Hi thanks for that!

Code is Running with uno/Nano/Mega.

I Did have the same Problem with a leonardo (at my lattepanda). I can See the Data with serial Monitor- But Not with Agopen.

I think the Leonardo Uses another thing for Communication...



Found it :

https://forum.arduino.cc/index.php?t...8.0#msg1074199

I think Leonardo Need dtr enable on Agopen side..

Questions on agopengps? Just look into the wiki at
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
. Thanks to all contributors!

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Andreas Ortner; 05-12-2019 at 10:13 AM.
Andreas Ortner is offline  
 
 
For the best viewing experience please update your browser to Google Chrome