s670 exhaust preasure code - The Combine Forum
 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 10-28-2016, 02:00 PM Thread Starter
Junior Member
 
Join Date: Oct 2016
Posts: 3
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
s670 exhaust preasure code

s670 sending a code saying I have low exhaust pressure and then putting combine into limp mode. If you shut it off and wait a few minutes it will reset. Also if you can push it real hard until the point off almost plugging, it usally will for some reason, reset itself but not all the time. Seems like it does it more when its cool outside in early morning or late evening. Also seems like it is wanting to do a burn a lot more. can anyone help with the problem?

smith ventures inc is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 10-28-2016, 07:59 PM
Site Sponsor
 
Join Date: Oct 2016
Posts: 8
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Quote:
Originally Posted by smith ventures inc View Post
s670 sending a code saying I have low exhaust pressure and then putting combine into limp mode. If you shut it off and wait a few minutes it will reset. Also if you can push it real hard until the point off almost plugging, it usally will for some reason, reset itself but not all the time. Seems like it does it more when its cool outside in early morning or late evening. Also seems like it is wanting to do a burn a lot more. can anyone help with the problem?
What is the code number you have? We can pull you the troubleshooting from John Deere.

DieselLaptops is offline  
post #3 of 6 (permalink) Old 10-29-2016, 06:26 PM Thread Starter
Junior Member
 
Join Date: Oct 2016
Posts: 3
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
I don't know the code number right now, but when it set a code before it said it was a faulty pressure sensor. I put a new one in, and with not many hours after that it did the same thing giving me the same code , so I put another one in. Not many hours after that it has done it again , so their is must be some other problem
smith ventures inc is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 11-03-2016, 04:54 PM
Junior Member
 
Join Date: Nov 2016
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
If the code is for exhaust pressure mismatch issue is most likely egr cooler plugged. Those ones tend to crack and leak antifreeze internally then plug up and will throw that code because no flow is detected when egr valve opens. Also makes sense why it doesn't do it as much when pushing it hard as egr valve won't be opening when under heavy load.
trav008 is offline  
post #5 of 6 (permalink) Old 11-06-2016, 09:49 AM
Junior Member
 
Join Date: Nov 2014
Posts: 17
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
If it does it when it's trying to clean the exhaust it is a plugger egr cooler like Trav said. Our 660 did this at 1200 hrs. Would run fine picking 8 rows of corn, the extra load when we switched to beans set it off constantly.

It's a pretty labor intensive deal to replace the cooler.
Barn door is offline  
post #6 of 6 (permalink) Old 11-09-2016, 08:30 PM Thread Starter
Junior Member
 
Join Date: Oct 2016
Posts: 3
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Thanks guys for the information, I will investigate and see what I come up with
smith ventures inc is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Combine Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome