9120 won't start and rotor wouldn't stop - The Combine Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 08-12-2018, 07:40 AM Thread Starter
Junior Member
 
Join Date: Sep 2013
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
9120 won't start and rotor wouldn't stop

I had to shift my rotor speed up and couldn't get it into gear, yes waited until it was stopped before I shifted it. The rotor was turning at 10 rpm but when you engaged the switch it said to turn off separator.
After shutting combine off a couple times it started with rotor in 3rd but the rotor was already moving. I hit the switch and all was good so I went till it got tough. When I disengaged the switch the rotor didn't disengage.
Yesterday morning started it up and rotor was turning again. Finished the field and put rotor in neutral so wasn't spinning for a longer move and started blowing the combine off. Ran for 10-15 minutes then sputtered like out of fuel and quit.
It wont start now. Fires for a couple seconds then seems like something is engaging and quits.
Any idea where to start. I'm guessing CVT is maby piled up.

sk case farmer is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-12-2018, 08:13 AM
Junior Member
 
Mikeruf's Avatar
 
Join Date: Mar 2018
Posts: 16
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Not sure why your combine won’t start but the reason the rotor wouldn’t stop turning is a faulty wiring harness. Have had happen a few times. Also sounds like you have some worn shift forks in your gearbox.

Mikeruf is offline  
post #3 of 5 (permalink) Old 08-12-2018, 03:20 PM
Senior Member
 
SWFarmService's Avatar
 
Join Date: Nov 2014
Location: Regent, SW North Dakota
Posts: 9,703
Mentioned: 6 Post(s)
Quoted: 2672 Post(s)
It's been a while but there is a wire connection under the buddy seat on the outside of the cab that fails not turning the rotor brake on.

Could try to put a different PTO brake valve cartridge in, they fail too.

Assuming the engine issue is not related but hard telling.

God Bless America
SWFarmService is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 08-12-2018, 06:56 PM Thread Starter
Junior Member
 
Join Date: Sep 2013
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I found out what the problem is, sort of. My rotor is staying engaged and my brake is also, that's why it wont run. I took the spool off the brake and could combine till it rained. Has to be a wiring issue but haven't found where yet.
sk case farmer is offline  
post #5 of 5 (permalink) Old 08-12-2018, 09:05 PM
Member
 
Join Date: Jul 2017
Location: Northern Alberta
Posts: 50
Mentioned: 0 Post(s)
Quoted: 9 Post(s)
I think once the wire harness on these combines start to give trouble it’s probably better to replace the entire harness. Otherwise you might fix one spot only for another to give an issue.
Cfarm is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Combine Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome