Turbo 2 on case 8120 - The Combine Forum
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 09-22-2019, 07:32 PM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Turbo 2 on case 8120

Has anyone ever installed Turbo 2 on combine and does it work.

Attached Images
File Type: jpg 20190922_170820_1569193818940.jpg (2.24 MB, 25 views)
Bytronic3015 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 09-22-2019, 08:39 PM
Senior Member
 
meskie's Avatar
 
Join Date: Sep 2010
Location: NE sask Canada
Posts: 2,382
Mentioned: 0 Post(s)
Quoted: 787 Post(s)
Couple guys put them on their NH this year. There is a thread about it on here. They might need them as a snorkel if it keeps raining.

meskie is online now  
post #3 of 5 (permalink) Old 09-22-2019, 09:24 PM
Senior Member
 
Join Date: Nov 2014
Location: NW North Dakota
Posts: 416
Mentioned: 0 Post(s)
Quoted: 100 Post(s)
Daner is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 09-22-2019, 10:21 PM
Senior Member
 
kevlar's Avatar
 
Join Date: Apr 2014
Location: central manitoba
Posts: 3,103
Mentioned: 2 Post(s)
Quoted: 973 Post(s)
So far a touch over 700 acres on the air filter since we put the pre-cleaner on our CX, it's starting to get dirty but it has been running in some horrendously dusty conditions, I guess with all the rain everything is rotting and covered in mold and mildew. Before this change I would guess we would be changing a filter a day in these conditions. I think if we had gone with something with a scavenging tube it would help even more. Overall I am quite happy, only regret is we didn't do it the first year we got it. I can't believe how many people are having the same issues. There has been quite a few people just on here that have had to do this, and this is only a very small percentage of farms running these machines.

It's easy enough to be pleasant, when life goes by like a song. But the man worth while, is the man with a smile, when everything goes dead wrong!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
kevlar is online now  
post #5 of 5 (permalink) Old 09-22-2019, 11:27 PM
Senior Member
 
Join Date: Aug 2017
Location: yorkton
Posts: 711
Mentioned: 0 Post(s)
Quoted: 115 Post(s)
Same issues on my 8780xp with Mav chopper.
I think extending the intake pipe would help the most, it is situated just too low.
100 hrs all I get out of a filter and its so plugged it is finished.
MF cowboy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the The Combine Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome