The Combine Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
122 Posts
Discussion Starter #1
my 06 378 the trailer ABS light comes on in the truck and the light on the trailer comes on when i hit the breaks, so I assumed that the trailer had a fault well I tested the trailer circut with an ohm meter and used a jumper wire to double check the trailer checks out fine, the center pin on the truck does not have power when the key is on or if the truck is running, I found the fuses and all fuses are good, found the relay behind the dash and the relay is good but i only get 3 volts to it, where I am at now is I need a wiring schematic or someone who has had this problem before to help me out. Thanks
 

·
Registered
Joined
·
1,244 Posts
Don't know if this helps you or not, but heres something i found last night while looking around for something else!

Q: Why does my ABS light come on when I hit my brakes?

A: Constant power is not being supplied to the ABS through the blue wire on your 7 way connector so every time you hit your brakes, the ABS system has to pull power off of your redwire (brake wire) and turns the system on and then it goes off when you let off the brakes. To correct this, make sure blue auxiliary wire is hot to trailer.
 

·
Registered
Joined
·
122 Posts
Discussion Starter #3
yep that is exactly whats going on with mine except that is worded better than how i worded mine. Im trying to figure out why I have no power to my blue wire when the fuses and relays (that I know of) are good, which is why im curious if there any other ones that I dont know about.
 

·
Registered
Joined
·
285 Posts
Have u checked all your wiring on each wheel of trailer, I would say a broken wire or bad sensor. This is a tough problem to find I assume the light goes out as soon as u unhook the trailer and that u have tried another trailer to see if the problem is not in the truck wiring? Had a ABS light come on the other day on my truck and stayed on for most the day when I turned it off and started it again it was out :eek:
 

·
Registered
Joined
·
122 Posts
Discussion Starter #5
tried a different trailer, its in the truck, no power to the blue wire in the pigtail of the truck
 

·
Registered
Joined
·
370 Posts
the contacts in relays can and do go bad from arcing, try a different relay, i have changed quire a few that sounded like they worked, but did not allow full voltage or amperage to pass through the contacts..
 

·
Registered
Joined
·
122 Posts
Discussion Starter #7
Switched relays behind the speedo still didn't have power.. Only had 3 volts to the relay. Are there more relays I don't know about? Not sure if there is a body control module on this truck reducing the voltage when it senses no relay in the system? Could a bad abs module cause this?? Don't want to throw parts at it until I know what's wrong
 

·
Registered
Joined
·
122 Posts
Discussion Starter #8
found and fixed the problem, it turned out to be a fuse. Moral of the story is always double check someones work it could save many headaches. Hired guy said he checked all the fuses, well he must not have checked or only checks one side. Burned out fuse was all that was wrong, replaced fuse and good as new. thanks for your help
 
1 - 8 of 8 Posts
Top