The Combine Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter · #1 ·
The splined hub that drives the hydro pump is starting to get a fair amount of play in it. I am down now with rain and was thinking of installing a different hub. Can this be done without removing the pump completely from the machine? I realize the shaft may have some wear also but was hoping to make that a winter project. Was hoping I might be able to move the pump away from the housing enough to work in a new hub without removing any lines. Anyone ever do this. This is on a 1470 which is same as a 1460 in this area.
 

·
Registered
Joined
·
192 Posts
I know on the 1680s and 23s I have changed those belts but man it's been a long time. That pulley should come out
 

·
Registered
Joined
·
112 Posts
Discussion Starter · #3 ·
An update. Yes it can be done. Previous owner had cut an access hole in the side of the body panel that covers the hydro pump. Without that I don't think you could do this the way I did it unless you removed the complete panel. I just looped a chain over the unloading auger tube and took a cable come along to lift with. Was able to push pump out of the way enough with all the lines still connected to remove the pulley through the belt opening. I suppose I was about 3 hours doing this so not real bad. The splines are wore on the pump shaft and a lot of the play is deeper inside the PTO once I got things where I could see what is going on. Guessing the flex plate may be where the main issue is. I hope this will get me through the rest of the season if the rain stops.
 
1 - 3 of 3 Posts
Top