The Combine Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1,246 Posts
Discussion Starter · #1 ·
My cab fan and AC has no function. The fuses are good but I seem to have lost ground at my blower motor. I ran a jumper wire to another ground source and the blower started working but the dial wouldn't adjust the blower speed and the AC blue light switch didn't show to be working. I traced the hot and ground wire from the blower to an aluminum box under and behind the operators seat. The box is about 5"x5" with other wires plugged into it as well. What is this and could it be my problem?
 

·
Registered
Joined
·
96 Posts
That box is probably faulty.Five years ago it was $AU 1200, probably only $120 in NA. Our blower fan motor was worn,which sent voltage fluctuations to the controller which would then fail. So it might be wise to replace the blower fan motors as well as replacing the box. You can hard wire the fan and AC to run flat out all day long. OK during the day can be a bit chilly in the evening
 

·
Registered
Joined
·
1,246 Posts
Discussion Starter · #7 ·
I got one out of an early model 2388 and plugged it up in my combine, but I didn't get any results. Maybe I got a bad one, but maybe I didn't. If that's not my problem what else could it be? They told me that the early 2388 was probably the same as a 2188, and I took their word for it.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top