The Combine Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter #1
I have an 02 2388 and am having problems with my air filter plugging. Its to the point where I have to blow it out 3-4 times a day. I have taken the precleaner off and blown it out, but that only will last for a day and its plugged up again.
Just wondering if anyone has run into this before and what your suggestions might be. Thanks
 

·
Registered
Joined
·
2,233 Posts
got that darn black plastic intake shroud, they warp, thus dirt, will crack, i remove and replace, when ya remove will see tin distorted, take a couple small hammers and straighen, should have had more support, i use larger washers, about 3/4 inch diameter, remove air cleaner assy, take air cleaner assy apart, venturius are full of sh't, blow and wash both directions, scott.
 

·
Registered
Joined
·
93 Posts
Discussion Starter #3
When you say you replaced the whole air cleaner assembly, does that include the muffler? By the looks of it, nothing will work unless the muffler provides enough suction to clean some air.
 

·
Registered
Joined
·
363 Posts
We got the same thing happening on our 7088. This is the second filter set we have gotten and the alarm is going off two or three times a day. We took the filter out and the date on it is May 03...we might have 40 hours, tops on this set and we haven't been working it that hard. We are going to try newer filters...
 

·
Registered
Joined
·
127 Posts
We have three 2388 one 04 and two 06,s the 06,s are fine but the 04 will plug the air filter everyday? Dont know what the differance is or whats going on?
 

·
Registered
Joined
·
27 Posts
Had the same problem on a 01 2388. We ended up changing the whole air cleaner assembly, also check and caulk everything to make sure no air is getting thru. Check your rotary gasket and all seals.
 

·
Registered
Joined
·
21 Posts
on your 04 check the little wrap that your rotating screen rests on we have two and they both got grooves worn in this piece. very costly to replace and it is a wear piece that can be fixed relatively cheap if it does not groove out into the actual screen frame. On the 02 get a smoke bomb and set it off inside your radiator compartment then start the taping and caulking of everywhere!! Good luck and hope this has been helpful.
 

·
Registered
Joined
·
22 Posts
The 7088s are not known for having air filter problems. Have you inspected your cooler box area for anyplace dirt may be allowed to get in?
 

·
Registered
Joined
·
363 Posts
We have checked for any leaks in the cooler box area and there is nothing. We decided to put a new air filter in and made it about 3 hours before it was plugged
It seems to be coming in around the latches on the 'lid' and we have put a new seal in, but it just seems to be letting the dust in. Tonight we put in the old, cleaned out, filter and duct taped around the outside and will check it tomorrow to see how it looks. Someone is suggesting the venturi's inside might be plugged...
 

·
Registered
Joined
·
998 Posts
Firstly, are your radiators / coolers getting blocked too?

Check "strata tubes" in black housing on air box. These should be clean as and not blocked or even melted as I have seen before. Also check to see if the black poly housing that wraps around the side that bolts to the air box is sealing correctly.

Check exhaust aspirator is working. This usually only removes large particles. Also check to see if exhaust pipe is still attached and not cracked off at turbo clamp. Air bypassing through a cracked pipe will limit air draw.

Best of luck.
 

·
Registered
Joined
·
363 Posts
We talked to a service rep and he suggested checking the outlet on the air cleaner housing that runs to the muffler.

We opened up the engine compartment and the pipe was right off the muffler and when we tried to put it back on the bottom slipped right off. After digging around in the opening on the housing, we found quite a bit of fine dust, so we cleaned out as much as we could, then put the hose back on and really tightened the clamps on both ends.

Once we started the combine and revved it up there was a fountain of dust shooting out of the muffler...I think the problem has been solved. Although we won't be sure until we get to combine again...if that ever happens
 
1 - 12 of 12 Posts
Top