The Combine Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Bought a 4720 with 1000 engine hrs and 490 spraying time. It seems there is a vibration coming from driveline/engine. I replaced the drive shaft and the vibration is still there from time to time. It usually comes around after I crest a hill and start on the the down (engine gets to 2510 rpm) thats when vibration comes on. It is a low pitch vibration. Is this normal?? Help. Also the my top speed is only only 25 mph, I have had it go 30 mph only twice. I was spraying in 2 nd gear doing 17/18, now it will only go 14.8. Any ideas on that one?? Thanks
 

·
Registered
Joined
·
2,500 Posts
Is the 14.8mph in 2nd gear at full engine RPM's? On level ground? As you said, it should do 17-18mph (at least, that's where our 4830 runs in 2nd). It may be a good idea to get the hydraulic system checked out. Maybe there is a pump starting to fail? Or even a valve not opening properly? Any other hydraulic functions causing issues?

Andrew
 

·
Registered
Joined
·
188 Posts
Had a new 4720 once that also had a vibration, tech came out, checked it out and said it was just the nature of the beast. Had it for 2000 hrs with no problems, vibration didn't get any worse or better, 2nd new 4730 is alot better, What's that ya say, I said! it's alot better...... (humor) Dave
 

·
Registered
Joined
·
431 Posts
I'm also wondering about the speed issue. I have engine rpm usually at 2480-2500 and it'll go about 15.5 or so in 2 gear with some instances upto 16. Also only 25 down the road. No hydro issues and recent greenlight. I don't mind the field speed since 15 is the optimal for drift, coverage, and pressure with my nozzles, but I'd like some more road mph.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
Engine was at full throttle, (2490-2512) I changed all fluids and filters. I agree 15 mph is a good field speed for me. I am just worried that something is wrong as it did seem to shift a few times into a faster gear giving me 30 mph on road, 21 in gear 3, 17 in 2nd. I can tolerate the vibration as long as it is the nature of the beast?? My dealer is sending the sprayer tech out. Thanks for the replies
 

·
Registered
Joined
·
3,102 Posts
The cable that comes from the hydro handle to the pump is adjustable at the pump. There are just two jam nuts on the cable, loosen and adjust the cable. If you USED to be able to go faster and now you cant, then, if the jam nuts are tight and haven't moved, that isnt your issue but they may be loose and backing off your adjustment. If you adjust it too far, the machine wont turn over with the key, you've triggered the safety switch, just back it off a bit at a time until the key will work.
 

·
Registered
Joined
·
34 Posts
Also wheel motor sensors go bad causing a drop on speed. To diagnose unplug them on at a time and drive it. The one that does not make any difference is the culprit.
 

·
Registered
Joined
·
431 Posts
Update: had jd mechanic out for another thing and diagnosed my problem. Front wheel speed sensors were good, but one side had poor ground. Traced back to a plug directly under the cab.
 
1 - 8 of 8 Posts
Top