The Combine Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I have a 08 575 with a Cat C9 acert. I was picking some down corn yesterday evenin lost a lot of power. I swapped both fuel and water separator today, but still with the threshing system engaged the combine says my engine load is 35 to 50%. Any ideas of what it could be?
 

·
Premium Member
Joined
·
6,063 Posts
If you do a search on the forum there was a similar question posted on the forum a few months ago. We had similar problems on our c13 but changing the water seperator filter corrected my problem. I feel for you. It is no fun to combine when your machine has no power. Mine died in the middle of a muddy slough.
 

·
Registered
Joined
·
70 Posts
Check the intake air plumbing. I had a rubber boot blow off between the turbo and aftercooler. I think it was the transition between the smaller outlet of the blower on the turbo and the large pipe that carries the air to the after cooler. Solved the problem with a new boot and 2 of the clamps on the large pipe.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Thanks for the help! I checked all the air plumbing and everything seems fine. I'm not blowing any color smoke. Before I tried starting the machine I pumped the fuel 5 or 6 times before the plunger got hard. But when I pump it I can hear it sucking air around the plunger and some fuel leaks out.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top