The Combine Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
2007 8010 radiator plugging with soybean fuzz. This summer the aftercooler was replaced, because the spinning cleaning fan blade cracked and rubbed a gash into the aftercooler. Before the aftercooler was changed, I needed to blow out the radiator once a month. Now I'm blowing it out twice a day. The seal on the rotating screen appears to be fine, I've looked at the door seal, and the rotating screen and everywhere else for a leak.

The coolant radiator is the only one that is plugging all the rest are letting the soybean fuzz pass through.
 

·
Registered
Joined
·
4 Posts
Check the intercooler pipes. I had to fill around these with expanding foam to stop my radiator and aircleaner from clogging

TH
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Had already caulked the intercooler pipes, The fuzz is very fine dust ( no large particles) and is 90% on the coolant radiator . The dealer mechanic has looked at it, and had no ideas.
This seems like such a simple problem, but we've spent hours and still have no clue.
 

·
Registered
Joined
·
301 Posts
Check your fan belt and make sure it is running around correctly. The fan belt will fit on two ways and will dramatically change your airflow volume. We found this out the hard way, but only after the belt that was on incorrectly when we bought it broke.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
The fan belt is on the way the sticker shows.

I'm still blowing dust out of the radiator.
 
1 - 6 of 6 Posts
Top