The Combine Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
521 Posts
Discussion Starter #1
Hello,
I am new to the Forum; so first let me say that this Forum is great!


I have a display problem on my 9600.
The display that I am referring to is the 6 function display (RPM, Ground Speed, Fan Speed, Cyl. Speed, Eng. Hrs., Sep. Hrs. , respectfully).

The ground speed works fine until you get above 11 mph. I have changed the sensor for speed (under the feeder house)....no better w/new sensor. Above about 11 mph, the display goes crazy....5.5......7.2.....9.4.......8.6.....10.2....etc.
The display reads "0" for fan speed (all of the time). I have changed the fan speed sensor...No better...The cyl. speed and engine RPM work fine. Eng. hrs. & sep. hrs. work fine, also.
I have checked continuity for these [malfunctioning] functions, and have it..

Local JD mechanic told me that I probably needed to replace the display unit. I purchased a used one from a combine salvage yard, but it was not the same thing...the used one had a function or two that mine did not have...I think it was from a newer 9600..??


So, my question is do you think that the new display will fix me? Since it is electrical, the JD dealer will be anal about taking it back.. Any advice greatly appreciated.
 

·
Registered
Joined
·
521 Posts
Discussion Starter #2
I sure might have...I was thinking, though...surely I am not the first that this has happened to.

To get down to it: I do not want to purcahse the $900 display new from Deere, just to have the same stuff continue to happen! If it takes $900 to FIX the problem, then so be it, as long as it FIXES it!
 

·
Registered
Joined
·
521 Posts
Discussion Starter #5
I did try the used one that I purchased. I plugged it into my wiring harness, and nothing read properly. I first noticed that the engine RPMs did not read properly...that was enough for me.
I sent it back, and got the proper part # from Deere.
If the co. gets the proper display, they are going to let me know..I was simply looking for advice and/or other options in the mean time.
 

·
Registered
Joined
·
289 Posts
Just try that used display you got first. Even if it's not exactly the same, it might still work. Displays can be updated. Some people do update their 9600s to 9610s. But I don't know the details, since I have not done it yet.
 

·
Registered
Joined
·
45 Posts
the monitors are set up for tire size and if it is not the right box it may not work they have like four dif. styles that they used in 9000 combines, dealer should be able to diag. down to exact problem. gl
 

·
Registered
Joined
·
521 Posts
Discussion Starter #8
Gosh, I did not know that the monitors changed according to the tire configuration! My 9600 has duals, so maybe that is why the monitor was not the same.

Thanks for the info. My JD mechanic has not been able to fix my problem. We have tried putting on new sensors, and that did not work. Now, he wants to throw new parts at it until it works...

Who knows? I DO know that I have gotten better ideas as to how to fix the problem than my JD mech. can provide.
 

·
Premium Member
Joined
·
1,236 Posts
If you have a newer display that shows the concave setting and feederhouse speed, you need to go into the setup of the display, so it will know the engine, tires, final drives and other imputs to work. The older displays had switchs on the back to do this, the new ones you have to push two bottons on the display and turn the key on to get to the settings.
 

·
Registered
Joined
·
521 Posts
Discussion Starter #10
motram5455:

Mine is the "old" version, 'cause my concave indicator is a mechanical gizmo outside the cab and not on the digital display.

So, are you saying that I can buy another display and configure it to my tires/wheels on the back with switches? Or do I have to buy a specific display from JD..?? (FYI: I am running duals..been that way since its' "birth")
 

·
Registered
Joined
·
45 Posts
monitor subs to new style that you program for your combine set up, it is easy to do. should have instructions on how to do. I have replaced many tachs for different reasons, if that helps. gl
 

·
Registered
Joined
·
521 Posts
Discussion Starter #12
Might I be so bold as to ask you for a the part number?

Or better yet, do you want to work at the JD Store that I so often leave not having any answers (or the correct parts!) ? HA
HA ..just joking about that...but seriously, if it is not too much trouble, could you give me a part number? My JD house is BAD about screwing up even the most simple things!

Just in case you need this info.:
JD 9600
Factory Duals, heavy planetaries
Currently I have a 6 function monitor
Ground speed (mph), Cyl. speed, Fan speed, Engine rpm, Engine hours, Separator hours~~respectfully~~

Sounds like you know more 'bout 'em than me!
 

·
Premium Member
Joined
·
1,236 Posts
I looked on John Deere parts catalog and the new number is AH163526, it is a kit with a wire harness, the are some old numbers also. Is there a number on the back of the display. Have your John Deere guy look at solution number 5640 to program the mointor. There is a s/n of 643900 and below will need a wire removed, it will be in the solution. Also do you have the sensors close to the gear or tone wheel to work.
 

·
Registered
Joined
·
45 Posts
motram is correct, but tx for compliment. I have worked very hard for jd dealer for almost 17 yrs and specialize in combines, planters and sprayers, so if I can help you I will try. Sorry you are so unhappy with your dealer. I hear this from people all the time , I travel a long way and go by other dealers to get there, why don't your dealer put you first and treat you like you are the ones that keep them in business and pay their paychecks, just don't understand.

ps make sure you get the right decal with your tach have had problems with not getting right one or there is a bunch and the one you need is missing gl
 

·
Registered
Joined
·
521 Posts
Discussion Starter #15
JdTech34:
The correct decal (with my tach)? I do not know what you mean...Do they include a bunch of different decals/stickers, and you have to label the buttons on the monitor?
 

·
Registered
Joined
·
45 Posts
the tach is used in many dif machines and they should have a bunch of decals, some of them look a lot alike so you have to make sure you put the right one on the tach according to your machine, sometimes they don't send the right decal for your machine so that is the reason I say make sure you get the right decal. should be a bunch in the box w/kit
 
1 - 16 of 16 Posts
Top