The Combine Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
2002 9650w 2500 engine hrs .. bought this year . having trouble starting engine after it sits for 2 days or more. had JD out they changed check valves and installed p trap. ? I still have a starting problem.. my dealer doesn't no what to do.
 

·
Registered
Joined
·
1,572 Posts
My machine ('03) had the same problem. The high pressure relief valve on the pump went bad and I changed it ($245 just for the 1 ounce valve). That seemed to help the poor starting somewhat, but it still doesn't crack off like it should.

Does it help if you pump up the system by hand before trying to start?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for the reply.. Ive tried pumping. even replaced the hand pump. also added a electric lift pump like the 9600's no luck. I have to crack the two lines going in the injection pump. then pump out the air. then it will start.. thanks for your help, I will try the high pressure relief valve
 

·
Registered
Joined
·
14 Posts
Had this problem for awhile with 9550w machine. If the 9650 has a water seperator filter, try changing it. We discovered that our filter was not seated correctly and was allowing air to enter system after sitting for a few days. I am referring to the spin on cartridge and plastic bowl located under fuel tank.
 

·
Registered
Joined
·
530 Posts
have the same problem with mine too. Dont really have a water seperator, it has a screen with plastic bowl under tank, but not similar to the 9600 element/bowl seperator. Ive changed all the check valves on mine too using the dealer and still same problem within three days time it wont start. My 8420 has the same engine with same filters and check valves and it has never given me any problems so Im thinking its not related to those parts but something else. Maybe on the return circuit? I dont know but Im not happy with the issue and have been fighting it for a couple years now.
 
1 - 5 of 5 Posts
Top