The Combine Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Im new to the site and also to a rotor. I engage the separator with the engine idle. Every time it is engaged the engine lugs sometimes to the point that I wonder if it is going to shut down. I replaced the fuel filters so I know its not that. The only other guess I have is that dust is settling in the feed accelerator and beater and then weighing it down for start up. Any thoughts would be appreciated.
 

· Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
I always engage the separator first but I am running the rotor close to max and the chopper at high speed. I did clean out the fuel sedament bowl which was really bad.
Sometimes as soon as I engage the separator, I hear a single knock. It sounds like metal on metal. I think its coming from the rotor pully but because it is not constant, its hard to tell. Sometimes it is louder than others. Has anyone heard this before? Thanks for the feed back.
 

· Registered
Joined
·
12 Posts
Discussion Starter · #9 ·
i am cutting with a 30 ft head. because i have the 9L engine i feel like i should not be able to run fast enough to make my engine light come on. i am running an average of 4.5 mph but it is thick straw. what is the best way to check that filter without draining the fuel?
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top