The Combine Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi Everyone,

First time post, have a problem we haven't been able to figure out how to fix. We have a 9610 John Deere Combine with 914 belt pickup header. The belt speed is set to speed up / slow down as the ground speed is changed. This has worked in years past but now the belt speed on the header will only speed up (will not slow down). It doesn't matter whether the pickup is in auto or manual mode, the belts will speed up but won't slow down.

We can manually slow down by turning the bolt controlled by the reel slow down motor (left side of the combine), but once the belts are sped up the motor won't slow it down again. We have changed out motor inside the black box and still no luck.

Any ideas/comments are greatly appreciated.

Thanks.
 

·
Registered
Joined
·
1,802 Posts
Switch is no good or you have a wiring issue. Have someone in the cab pushing the button and verify there is power coming to the motor.
 

·
Premium Member
Joined
·
552 Posts
Outside the cab on the lower right hand side you will find a couple multi pin connectors, which connect all the cab's electrics to the main electric control box. Give both connectors a clean out with air and some WD40. Sometimes the connections in there dry up over time.

If that doesn't help, check for power at the control box. There should be a relays and/or breakers for the Dial-a-speed circuit board, which plugs in underneath the main circuit board.
 
1 - 3 of 3 Posts
Top