The Combine Forum banner
1 - 5 of 5 Posts

·
Premium Member
Joined
·
989 Posts
Discussion Starter · #1 ·
We have a Brent 1594 cart that we purchased just over a year ago. Hooked it up to get ready for harvest and the scale read all over the place. Took it to the field to find that it is not working at all, basically gives loopy readings and then when its full it won't go above 2500kgs. So with the rain I decided to drop it off at RME and see if they can figure it out. They've had it for over a week and have come up with nothing. Apparently it passed all of the troubleshooting guides that Brent supplied them with and now they have no idea where to go next. I called Brent and hopefully they get back to me right away. Unfortunately we're ready to start combining again tomorrow so looks like I might not have a scale this harvest.

Does anyone have any ideas?
 

·
Premium Member
Joined
·
4,393 Posts
First check all your cabling, make sure there is no issues there. If you find the junction box on the inside of the frame where all the load cells plug into which is called the J box. I believe you can unplug one load cell at a time and see if its one of the load cells giving you issues, you will have to change a setting in the monitor while testing. I had to replace the hitch cell on my old 1594. I assume that your dealer would have tried that already tho.
 

·
Registered
Joined
·
379 Posts
Did they check the monitor as well or just the cart. Our 1084 did something similar and it ended up being a bad monitor, cart passed everything but poor and no readings on monitor. Good luck with it.
 

·
Premium Member
Joined
·
8,228 Posts
On my Brent 1594 half the load cells were installed upside-down! You might want to check that but I am sure it was one of the first things in Brent's troubleshooting guide.;)
 
1 - 5 of 5 Posts
Top