The Combine Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
our 1680 has a bad vibration that goes away when the feeder drive is disengaged. Almost all moving parts have been replaced with new genuine caseih stuff, but the problem persists! The dealer says they all do that but that's not my experience. any comments, ideas?
 

·
Registered
Joined
·
223 Posts
Do you have a rock trap? Ours does and had the same problem check chains and sprockets for wear. Also the tension arm that the spring pulls on and check for wear, where it rubs against the bracket. It could be out of linecausing the chain to bind.

Good luck
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
we have disconnected the header, it's definately the feeder.what do you mean by the tension arm? are you refferring to the feeder chain tensioning roller setup? yes, ours does have the rock trap.
 

·
Registered
Joined
·
106 Posts
Does it vibrate on start-up or the whole time? It sounds too obvious to be chain tension, but in all reality the problem is right in front of you. There aren't too many points to troubleshoot.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #8 ·
I know it's only a feeder house, that's why it's so frustrating!!!! After thousands spent at my caseih dealer they can't seem to fix it. The chain tension seems ok as per the owners manual. Still looking for help! thanks
 

·
Registered
Joined
·
2,232 Posts
remove chain, does rock trap beater turn smooth or bind, i bet ya got a brg going out, or bent shaft on feeder drive top sprocket, bent shaft on rock trap assy, on front drum, bolts missing, or shaft, drum bent, i would pull feeder chain, you will find your problem, scott.
 
1 - 9 of 9 Posts
Top