The Combine Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,552 Posts
Discussion Starter · #1 ·
Bought a used Chem Handler to set up a second spray trailer. Have a straight shot on one which works fine. The Chem Handler which says III on it is plumbed 2 inch . Guy used it stepped down from 3 inch said it worked. Won't draw chemical out of the hopper with 2 inch when hooked to the sprayer but will draw slowly if you just let it blow out of the handler without a hose.(No back pressure). When we examine the venturi the arrow is pointed the wrong way and it is on there backwards. We turned it around so the arrow is pointed forwards and it won't pull at all. Nothing. So it will pull slowly out of the hopper backwards, opposite to the one on the straight shot, but won't pull when it is plumbed properly. We see pictures on the net of the venturi having an insert at the intake end which we don't have. Anybody know how to fix this issue?
 

·
Registered
Joined
·
296 Posts
I remember there was supposed to be a replaceable fitting somewhere in the venturi system of the Flexicoil sprayers that after a few years of use would wear and the sprayer mounted chem handler would quit drawing chemical.
 

·
Premium Member
Joined
·
2,425 Posts
Hope you are not like me the first time I used my auction purchased chem handler. Hooked inlet into the outlet. Took 1/2 hr to figure out I was being stupid, again.
 

·
Registered
Joined
·
4,715 Posts
Seems to me that Venturi is just a molded piece on the chem handler’s.
The pressure side will be only to the nozzle, it will blow about a 3/8” stream through a larger passage that will be connected to the chemical and the combination will exit the straight shot through side if it’s connected properly.

And obviously the clean water in should be on the flush valves side.
 

·
Registered
Joined
·
208 Posts
should be an ice cream cone shaped gizmo in the venturi on the straight pressure side, not the triangle side. I had this issue as well and it was on backwards and I noticed the piece in there when I swapped it around

this link shows the piece
 

·
Registered
Joined
·
1,552 Posts
Discussion Starter · #7 ·
We are definitely missing the nozzle insert inside the venturi. I have found one in Winnipeg and will install tomorrow. Hopefully we can spray again soon and try it out. Wet and looking wetter this afternoon. Thanks for the help!!
 
1 - 7 of 7 Posts
Top