The Combine Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
477 Posts
Discussion Starter · #1 ·
My close friends in Ag service tell me the Lincoln auto greaser has failed more times than once in Sask., causing ungreased bearings to fail on new machines....We had 1 combine with Lincoln on a '11 750 Claas, it worked well and without fail, I believe now only the CLAAS auto greaser is available from factory. Is anybody experiencing failure or issues with CLAAS auto greaser? I'm deciding whether to cancel this luxury to my '15 order....
 

·
Registered
Joined
·
982 Posts
Did someone explain the failure to you? I think i would want to know how the thing failed first before deciding… If its only one bearing that didn't get grease it may not necessarily be the fault of the auto greaser.
 

·
Registered
Joined
·
680 Posts
I have a Lincoln auto greaser on my Mack truck. If any of the grease fittings do not take grease the pumps shoots grease out at the main tank from the relief. All the fittings are in series, so the system can't keep greasing when one gets plugged. I guess that can be a negative if you don't notice that on is plugged than nothing gets greased.
All the grease blocks can be checked quickly and easily by manually greasing at each block.
 

·
Super Moderator
Joined
·
5,041 Posts
Cue appropriate music!


Just watch the first 35 seconds for this post's purpose.

It's a machine of mystery to me, says it's malfunctioning on CEBIS yet uses grease so how is it malfunctioning?
Greases more often than it should IMO, but there is no way to set anything.

Like fuel tanks and Telematics I just keep ordering stuff like this based on the theory they'll eventually get it figured out.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top