The Combine Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
hi folks. 02 cts . seems to be giving me intermittent electrical trouble. seems not to charge batteries only sometimes and then fine other times. eliminated the loose connections theory. this evening hard to start but when we got it running it would only rev to 1870. only new to cts so not sure i this is 1 or a few problems together. machine has low hours and been extremely well maintained.
 

·
Registered
Joined
·
60 Posts
Not sure but guessing you have a 9650 CTS, there most likely cause of it not charging is the exciter diode attached to the D+ terminal on alternator or you have a dead battery or failing alternator. If battery voltage falls below 10.5 volts you can see issues with revving up etc
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
thanks jdaussie. measured voltage and all seems ok.this problem is intermittent.machine eventually starts but will only run to 1870 revs as if in third gear. after 30 mins of this yesterday the machine then ran fine. local jd combine mechanic seems to be convinced its a circuit board behind corner post in display unit. i worked the machine yesterday with diagnostic plugged in but nothing showed while machine was working fine. its a very tough season here and yesterday was one of the better harvest days which was almost totally lost. the circuit board is very expensive and we dont want to purchase the unit unless we are sure its the prob.anyone with similar experience, would love to hear. cheers.andy j
 
1 - 3 of 3 Posts
Top