The Combine Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
I have a 67xl flexi sprayer with a sp65s controller. My auto rate controller has gone on the fritz. In manual mode I can turn the pressure down but not up. In auto mode the same thing happens. Voltage is good at the 3 way valve when the + button is pressed. Any ideas?
 

·
Registered
Joined
·
219 Posts
I would bet your valve control motor is going. We have one acting up as well and will likely put a new motor on in the next few days ( we keep one of them as well as pressure and flow sensors on hand).
 

·
Registered
Joined
·
54 Posts
Discussion Starter #3
Ry0972-do you use a motor from flexicoil or have you found who makes this for flexi? I think the stealership quoted me around $1200 for the motor/valve assembly. TIA
 

·
Registered
Joined
·
219 Posts
We have/had a spare OEM motor on hand. changed it out and ours is still slow to adjust pressure (sometimes wont adjust till I do it a bit manually) we lubed the stem that comes out of the valve and that seemed to help. It will increase the pressure most of the time but decrease is rare ( as it has to fight against the water pressure to close valve) unless it tries in some rough stuff then it usually works. I think if I get time I will pull the valve apart and clean/check/change it, When they say 12 inch pounds on the valve bolts they mean 12 MAX.
Tried our spare monitor with same results.

When we bought the last two motors they were $500 each and high $600 with the valve. When/if you just buy a motor get the drive coupler as well !!! They are usually rusted on so you have to pry the plastic part off and heat the steel collar to get it off (did two today without damage) Loaded it up with Anti-seize when it went back together.
I wish the sprayers were plumbed with the band clamp style fittings instead of threaded ! Depending on year and options it can be fun getting a broken/leaking fitting out/fixed.
 

·
Registered
Joined
·
1,861 Posts
You can buy just the motor. You don't need the valve. Don't throw that motor away, they can be fixed easily by an electronics tech. The motor should only be 4-500can.
 

·
Registered
Joined
·
2 Posts
came across this old thread as I am having a similar issue with the sp655 controller on my old model 62 sprayer . I believe my problem lies in the controller, just looking for any additional insights anyone may have before replacing it, if I can find one.

Having trouble with controller operating the 3 way valve.
- On startup and for about 1hr of operation, all was good. Then auto rate controller closed valve and will not open it.
- Removed motor from valve and finished field without auto rate.
- When I hooked motor back up next day, seemed to be operating properly again. Motor turns both ways, a little slower one way. (About 8 seconds to go one way, 6 the other).
- I decided to open up controller to see if anything was visibly lose or damaged. All looked ok. Cleaned it up and put it back together. When I hooked it back up to controller, was way slower going one way. Probably 10-12 seconds. A few cycles through it and it was worse. To the point it was no longer operable.
- When I connected the monitor bypass (grey thingy), it would quickly turn the motor - I didn’t have it on the valve but I assume this is to turn it to full open position. When I then connected monitor again, it would turn it quickly one way but pretty much dead the other. So thinking the problem is within the monitor / controller unit?
- had the motor checked at an electronic shop first time this happened so don’t think it is the motor. It tested fine.
 

·
Registered
Joined
·
425 Posts
I had a prototype Val air sprayer with a flexicoil rate controller in it. Was always giving problems so I changed it to a spraymate system with a gps type signal for speed. Super accurate system and very easy to plumb in to the liquid and electrical. Have a raven not and it’s a pos in comparison. Think I paid 1400$ for the complete kit 15 years ago and remember seeing it recently for not much more.
 

·
Premium Member
Joined
·
2,113 Posts
I thought micro trak was out of business? I may be able to bring a sprayer back to life now. Affordably.... Looked up spraymate and was rather amazed to see what I found. They are a good simple rate control system.
 

·
Registered
Joined
·
2 Posts
I did figure out my problem. I was wrong about it being the monitor. Had rewired it to bypass the monitor so I could at least adjust rate from the cab, hooked that up and did the same **** thing! Took cover off motor again and played around with it. Tapped one of the switches that limits its rotation and voila, back in business...
 

·
Registered
Joined
·
1,412 Posts
I did figure out my problem. I was wrong about it being the monitor. Had rewired it to bypass the monitor so I could at least adjust rate from the cab, hooked that up and did the same **** thing! Took cover off motor again and played around with it. Tapped one of the switches that limits its rotation and voila, back in business...
As this thread was progressing I thought of the limit switches inside. Kind of cheezy little things that see a lot of use. Glad you found it! Similar to limit switches on old three ton two speed axles that were the usual problem with them quitting. IIRC you could buy the little circuit board with the new contacts and get you going again.
 
1 - 10 of 10 Posts
Top