The Combine Forum banner

Hydraulics Overheating

5757 Views 6 Replies 3 Participants Last post by  460
CTS Hydraulic light coming on. It seem like it's building up pressure in the valve body and not bypassing. If we shut it off and start it up no noise in electro over hydraulic body. Then if you hit any hydraulic function and release it still sounds like your holding a button. Checked the limit switch on auger but that seems to cut out when you swing auger back.
Any suggestions this is slowing us down and not sure where to start.
1 - 7 of 7 Posts
on our 9750 the spring broke in the valve that closes the flow that makes the pressure build up. this kept the flow blocked and the system was like you were holding a button down all the time causing the oil to overheat. when you push a button two valves will activate, the one to stop the bypass and the one where the oil is supposed to go ie header , unload auger etc. the common valve is maybe your problem. It sounds like you have a hydraulic load all the time. In an old 8820 the unload auger valve would stick when we swung it in causing this problem.
Thanks, there was a spring broke in the relief valve body, I think we solved the heat issue. But the reel won't go down unless you shut the combine off. We got the parts late so will look at reel valve body in the morning.
you could still have part of the broken spring in there somewhere or you could have another broken spring
Inspect for a damaged R27564 O-ring on the poppet in the number 1 dump valve. If this does not correct the problem, then disassemble the valve and inspect for debris plugging the seat under the solenoid poppet and the orifice. Check for spool binding.

i had a 9600 do this same thing last year, overheating and reel wouldn't go down. the oring was cut

See less See more
Not overheating now. but reel still won't go down once the oil gets hot. We're doing lentils now so the reel is running right down all the time. We were hoping to get caught up so we good do some more troubleshooting. I will check the o-ring. Thank you very much more the info.
Pulled poppet out behind plug, we found 1/3 of 0-ring gone. Problem solved. We had inspected poppet beforehand but didn't check that o-ring. Thank you, ststech.
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.