The Combine Forum banner

1 - 4 of 4 Posts

·
Premium Member
Joined
·
4,367 Posts
Discussion Starter #1
So we have not been having very much luck with this new feeder-house, the slip clutches as well as the pickup clutches have been terrible and my dealer has ordered new ones and installed them but they are not much of an improvement. When harvesting canola you will hit a pile and plug the feeder & pickup prematurely and it wouldn't reverse it properly. It will just sit there and ratchet the clutches until you turn it on and off about ten times and then they grab somewhat. Reversing the feeder is becoming at least a min long job when it should be a 10 second deal. We had 2008 9870s and the clutches were adequate but the 2009 models are horrible and the new parts that Deere is sending out are crap. We also had to take a link out of the chain so the tensioners could work properly to help stop them from jumping a cog which to happen every few days, which still happens after Deere so called "solution". We are really having trouble getting proper capacity out of these machines, could probably have bought a 9670 or 9770 and got the same amount done this year. Please tell me i'm not the only one, we have the same results on all 4 of our bines.
 

·
Registered
Joined
·
31 Posts
Re: I HATE the new 4x4 feederhouse, anybody with m

jdmanitoba........ Have had feeder house problems also..

What is the Deere solution to feeder chain sprocket jumping?

Our Dealer tech rebuilt our slip clutch with heavier springs... seems to have solved our problem.

Chain jumps sprocket(s) occasionally.

Biggest problem this year was plugging the discharge beater in canola.... what a nightmare!

Dealer techs finally installed a couple paddles to replace the tines on 21 and 22... third and fourth last..... haven't plugged since... fingers firmly crossed!

Our 635D header is another story!.... Bill
 

·
Premium Member
Joined
·
4,367 Posts
Discussion Starter #3
Re: I HATE the new 4x4 feederhouse, anybody with m

Well the feeder chain jumping was initially cause by the new chain stretch and then the tensioners would max out and then it would get loose. The bad part is that the indicator would show that the chain was tensioned properly, and it would take a second glance to notice that they were maxed out. Some of the other 2009 models in my area got loose and then jumped a cog and then broke the chain so our dealer came out and took a link out so the tensioners would be back in range. The feeder clutch has been rebuilt by the tech and several were actually missing springs, they were better but still pathetic.

Do you notice that the new feed acc has a triple belt on it so it almost never plugs but now the beater has issues. I spent almost 7 hours to unplug one after some tough pea harvesting. We never plugged ours in canola . . . ever, only in wheat, barley, oats, & peas. But once we got a rain then the straw died down and we never had problem for the last 3 weeks of our harvest.
 

·
Registered
Joined
·
31 Posts
Re: I HATE the new 4x4 feederhouse, anybody with m

Yes... the feed accelerator drive is the heavy duty drive with the high capacity feeding package.

I plugged the discharge beater twice.... still have bruises and scrapes on right arm and torso....

The discharge paddles seem to work... they do make sense.... and they should be stock!

Nelson's... our dealer... also found a pulley from a 290 windrower.. I think... and an appropriate belt which speeds up the discharge beater.

I straight cut some canola ... grain was 7 1/2% moisture... but the straw was very green and it went through ok, but the slip clutch on the 635D feed drum is far to weak to really test the discharge.

This header is extremely disappointing...... Bill
 
1 - 4 of 4 Posts
Top