The Combine Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
the pto quit working on dads 1586 the neighbor said to put on a pressure guage and it is making no pressure. I tried to fiddle with the valve assembly but I cant remove it. I unscrewed the top part of the valve but it seems to be held in by a spring or sometiing. I also removed a plug directly below the valve but nothing came apart there either. Is there a procedure to service the valve or do I need to remove the whole pto?? also I guess something could be clogging the pickup tube or I think they sometimes fall off?
 

·
Premium Member
Joined
·
5,233 Posts
Been a few years but yes the valve can be serviced while the unit is bolted to tractor. In my experience, since you have lost pressure and it is no longer working, odds are it will have been slipping and should be rebuilt. More time and labor than parts, but there is a possibility you have issues internally.
 

·
Registered
Joined
·
4,919 Posts
I'm like AB, its been a few years. The valve assembly has an internal roll pin that can either break or fall out. Given the fact that you have no pressure, I am willing to bet this is the case. IF I remember correctly, the valve assembly comes out the bottom of the PTO housing, there should be a plug directly under the valve. If this is the case then you have an easy fix. Just remove, new pin, reinstall, check and set pressure, and you are ready to rock and jam.
 

·
Registered
Joined
·
45 Posts
If you do have to remove it we found parking the tractor on a steep ditch facing downhill is the quick and easy way. All the hydraulic oil runs to the front and you just unbolt and remove the pto assembly. We can have one out, rebuilt, and reinstalled in about two hours.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #5 ·
I did get the valve taken apart but couldn't totally remove it because of the hitch beign in the way however the valve must have been stuck because now the thing is working after I put it together. the only prob is it only makes 100 psi max so I need to figure out how to get the pressure higher it adjusted all the way up already
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top