The Combine Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
221 Posts
Discussion Starter · #1 ·
Just wondering if anyone out there has had any issues with the hydraulic pump on the 30 series JD tractor. We bought a 7130 new in spring of 2012 and just traded it off at 1400 hrs. I was not totally happy with the tractor in the first place as the hydraulic pump is a mishmash between open center and closed center. I thought open center systems were a thing of the past and did not know what i was getting after the fact, my fault totally for not doing my homework. I do not enjoy roaring my tractor to speed up my hydraulics. Secondly, I was not happy with the power of the tractor. Rated at 115 engine and 105 pto, i thought it would compare to our 2000 Case MX 110 in power, which is rated be about the same hp. Not. The Case will bale about 3 MPH faster (we bale straw as fast as we can feed it or ride the field) and has more power up hills than the 7130. Max speed was about 9mph with the JD, 12 MPH with the Case. Comfort wise both tractors were on par, the case shuttle was much nicer as it to put it in N, U just pull the shuttle toward you when it is in F or R, where as the JD U have to put your foot on the clutch, or put it back in N, a bit of a pain. Would buy that Case again new in a minute if they still made it. Anyhow, back to the pump issue with the 7130, at about a year and a half and 1000 hrs we started having issues where we would loose all hydraulics and steering. We were ready to haul it to to the dealer and went home to pick up the trailer to load it and after a few hours shut off, it worked fine again. We did not haul it as we needed it at that time and it was working fine. To make a long story short, at 1350 hours and 2.5 years, 6 months off of warranty, Hydraulics quit again and this time, after shutting the tractor off, we could only run it for about 10 mins before no hydraulics again. Dealer diagnosis was hydraulic pump was toast and we need a new on at $1500 plus labour. Not happy . Dealer and JD covered cost because we had extended warranty coverage, but traded tractor ( on a JD 6150M) because did not want to speed $3000 every 1000 hours of use. I believe the issues started when we would forget to return hydraulic lever back to N when closing the baler hood and pump was running under pressure until the next bale was completed. Regardless, it happened all the time with the MX and its still going at 9000 hrs. Just thought I would put it out there to see if this is an issue with these 30 series tractors or if we were 1 of 1.
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top