The Combine Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Looking for some advice with a mt665b tractor. Im new to the forum but have followed it a little. Issue I'm having is remotes either don't work at all or pulse rapidly. Now when its first started up and the remote is engaged it will work fine then starts acting up. the unlock switch flashes a sequence of 2 3 3. Also has a code that beeps often a d156. Tractor has been some what of a electronic nightmare. Its had new pumps new remotes. New whatever else the dealer "thought" was wrong
 

·
Registered
Joined
·
118 Posts
the pulsing sounds like an accumulator charging.I've seen were the seat of the cycling valve was shot and would leak the accumulator pressure down
 

·
Registered
Joined
·
26 Posts
Also check for the pressure sensor if it does not read pressure it will act like that alot had a jcb 8250 do that and i noticed my 665b has about the same system on them. all the new ones have a pressure silenoid it can be expensive but simple fix the one for my 8250 was 950.00 dollars so you want to make sure
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Okay. Finally have some time to start on this tractor. Thank you for the info . Ill see if we can figure it out
 

·
Registered
Joined
·
1 Posts
Looking for some advice with a mt665b tractor. Im new to the forum but have followed it a little. Issue I'm having is remotes either don't work at all or pulse rapidly. Now when its first started up and the remote is engaged it will work fine then starts acting up. the unlock switch flashes a sequence of 2 3 3. Also has a code that beeps often a d156. Tractor has been some what of a electronic nightmare. Its had new pumps new remotes. New whatever else the dealer "thought" was wrong
Hey I have a challenger 665b doing same thing can't seem to figure it out was wondering what you done to fix yours
 
1 - 10 of 10 Posts
Top