The Combine Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
196 Posts
Discussion Starter · #1 ·
Have a 01 2388 and cutting wheat. Combine sitting everything engaged at full throttle, engine RPM's are 2470 rotor RPM's are 1000. But if I push it and the rotor RPM's drop to 850 the engine is still running 2430 RPM's. The motor shows no sign of being worked or having a load on it. checked both sheaves in the engine compartment and the driver is just under 3" and the driven {the one that is on the rotor gear box} is 3 3/4" from outside to outside. I checked my cam followers they move freely, but should I be able to just grab them and spin them, with out taking tension off of the spring. Need help this combine is not performing like it should.
 

· Registered
Joined
·
196 Posts
Discussion Starter · #5 ·
Well Scott is the winner, the three groove belt that runs the rotor drive was a bit loose. (when we were putting the new three groove belt on the tensioning spring had screwed it's self into that half moon block.) And the rotor belt was not in the shieves acording to the book. Thanks to all that replied I really appreciate it!!!
 

· Registered
Joined
·
196 Posts
Discussion Starter · #8 ·
HOLEY CRAP, I did the fuel pump adjustment that BIG A talked about a while ago , on a different thread and man what a difference. I am so glad I saw that and gave it a try.

gotta love this forum!!!
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top