The Combine Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
I have a 2008 R65 combine with a Sisu engine. I was driving down the road and the alarm said low fuel filter pressure. Put new filters on and now they won't fill up with fuel. Got to checking and I don't think the fuel feed pump on top of the first filter is pumping(couldn't hear it or feel it). Tapped on it and it would run for a second and then go off. Has anyone had any trouble like this?
 

·
Registered
Joined
·
29 Posts
Have an '06 with Sisu. Replaced that pump last year. First make sure fuel is getting to that point. You have to buy the whole assembly to get the pump. Don't ask me why. Took pump off new assembly and put on old housing. Did not want to take all those lines off in the field. Might want to double check and clean mesh line filter if you haven't done so. Seems just about everyone has problems with plastic filings plugging it.
 

·
Registered
Joined
·
409 Posts
Exactly the same thing happened yesterday on my A75. Low fuel pressure and engine derating. Cleaned in-line strainer and fuel tank vent line. Ended up replacing pump and filter for 375$. Why can't we buy just the pump?
 

·
Registered
Joined
·
590 Posts
In our area the dealer has us put the spin on water separator/filter under the cab on the line out of the tank like the older combines used to have so that it can catch the stuff first thing out of the tank and easy to change without having to mess with the goofy inline strainer. The spin on catches all the bigger stuff before the inline so that it stays clean and then we mainly only have to worry about the other filters.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top