The Combine Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Inside chopper blades much more used up than left outside, high speed chopper and 1/2 paddles gone, sweeps , s77 2013, added high speed chopper and hard trouble with belt hopping off one groove, way too many problems with this combine, any ideas, thanks
 

·
Registered
Joined
·
382 Posts
Is the spring loaded idler lined up true with the drive pulleys? I installed a high speed chopper in our 77 and when you have to relocate the bottom idler I seem to remember having to shim that out some so it was true with the bottom pulley. Chopper worked great for us ran the knives just under half way up. Not real excited about the troubles I have heard with the drive u joint. Can't help much on the wear situation on the hammers. Wonder what the helical position is like in the cage on the discharge.
 

·
Registered
Joined
·
735 Posts
I feel you have to add 2 forward bars clear to the end of rotor. Removing 3 paddles is just going to slug the chopper more. I know removing the paddles are what agco says but you really need to move the material out farther to the left. I don't know of anyone else that does this but my knives now wear much more even so I feel that I am gaining hp by even feeding the chopper.
 

·
Registered
Joined
·
1,276 Posts
Ericks, I have Brian sending me some pictures on your sweep setup. I am seeing quite even wear on knifes with your setup. I have to see how your sweeps were installed and that might tell me story. Yes make sure idlers are lined up for belt jumping over (that just not normal at all).
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top