The Combine Forum banner
1 - 13 of 13 Posts

·
Premium Member
Joined
·
27 Posts
Discussion Starter · #1 ·
Anybody out there have problems with the “solenoid Coil threshing mechanism faulty on” message ? It stops the feeder house. Then goes away. I switched coils and still comes up. It is on a 2015 760 Lexion
 

·
Premium Member
Joined
·
5,905 Posts
When it fails see if there is power to the solenoid. It maybe the solenoid is fine but there is no power to it. To over ride the solenoid you push the in the small little pin in the center where the round knob is.
 

·
Premium Member
Joined
·
27 Posts
Discussion Starter · #3 ·
It’s a momentary fail. Looks like I have other electrical issues as well. Chopper out of position and main belt slip alarm comes on at the same time those alarms come on, the auto header height control quits working. ☹
 

·
Premium Member
Joined
·
5,905 Posts
On our 590's under the big shield on the left side at the back towards the top there is two modules that control some of the electronics of the machine. You may want to make sure the plug has not slipped partially out or is corroded. I would also check the breaker panel to make sure the main connections are not loose. You may also want to follow the ground from the battery and maybe clean it where it grounds to the frame. Electrical problems are never fun.
 

·
Registered
Joined
·
1,150 Posts
When you get multiple electrical problems at the same time 99% of the time its ground related..... check any grounds that are common to the problem circuits... if you have a nice dealer they may print out the schematic... then you get get your crayons out!
 

·
Registered
Joined
·
1,513 Posts
Wiring /connection issue. Likely nothing wrong with the coil. Clean and inspect all connectors between the coil and the controller. Fun/Fun.
OR...it could be a ground or...the controller for all those things failing.
 

·
Registered
Joined
·
21 Posts
I have been having the same problem. I notice though that the returns light goes off in conjunction with the header and separator turning off.

Any chance you found the problem?
 

·
Registered
Joined
·
21 Posts
I wondered about that, as I did notice the battery light on the column.
And I got an alarm for battery overvoltage, followed by many other failure messages :(
 

·
Registered
Joined
·
21 Posts
I took the alternator into a shop which could test it, and was told that it was indeed overcharging the battery.
Too long leaving it like that and the battery would boil dry and explode. Not a fun time!

I did end up changing the alternator (~$1100 CAD) and all problems went away :)
 
1 - 13 of 13 Posts
Top