The Combine Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 2000model 2388 and the touch screen is on the blink.It only works when I get it really cold. When I get in the cab and the temp is over the hundred, I have to put the a/c to max for at least 20 minutes before the screen works. It does not respond to anything I do, until it is cool. Even during the day I sometimes have the a/c set cooler than I like and the vents set on the screen so it will work. Has anybody got a solution? I went to my dealer a there is no parts listing for the screen itself, just the whole monitor, and the price was over the top.
 

·
Registered
Joined
·
3,334 Posts
That is really weird.......

surely someone fix's them id think....

im guessing it has to be something internal

Do you take it out before the winter time and before it gets really cold?

just curious
 

·
Registered
Joined
·
2,199 Posts
Quote:you could always take the cab off and harvest your crop in the winter. sorry I could'nt resist.

What, do you deere guys do that or something?






Sorry, couldn't resist x2

-Lance
 

·
Registered
Joined
·
100 Posts
Seems that sts combines only work properly without cabins and under cold circumstances!!!!! Thinking about them next cold fall season!! Poor guys running their division!!!

Sorry, couldn't resist x3

Tomih
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
All very amusing, guys. I like your style. I used to own a round back 95 Deere with no cab, not an experience I want to repeat.[Either of them] Still a weird situation. Do the crystals in the screen deteriorate over time?
 

·
Registered
Joined
·
2,199 Posts
If the cold weather destroys a LCD, then why is it that all the new cars that have onboard navigation are using a LCD as the screen? Every AM/FM radio produced in the last ~20 years uses a LCD for the display, and those don't have any problems either. I also have a laptop that lives in the trunk of my car. First an HP unit and now one a dell - neither of which have ever had screen issues from being frozen.

-Lance
 

·
Registered
Joined
·
3,334 Posts
Ive always been told to take them out cause the really cold weather is bad for the screen

so...just thought id toss that out there
 

·
Registered
Joined
·
192 Posts
I had the same problem with a AFS display today on a 1200 planter. Talked to TSG about it and they said that the screen has conductive material between two screens thats seperated. You can genty press the upper left hand corner of the screen where the black and clear come together, then the screen might work. My customer tried and it worked, but that is temporary fix. Talk to Ag-Exress and they said the Des Moines IA office can fix them. Hope this helps.
 

·
Registered
Joined
·
192 Posts
casefarmer I talked to a different guy on a speed problem today. I went to his place to see what happened. It worked fine last year. Did what the BIBLE said and they told me they had it fixed in D-M IA and was planting today, but you need to recalauberate. I might need to see how people our treating these systems to help them out on this problem. This stuff is not going to take the beating the older stuff did.
 
1 - 11 of 11 Posts
Top