The Combine Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I have a John Deere 4450 that displays the transmission pressure light upon startup, and it indicates to shut the engine off. Where are you able to check the hydraulic pressure on the transmission on this tractor.
 

·
Registered
Joined
·
520 Posts
Below the lh battery there is a tin cover remove it and behind it is the clutch vavle there is test ports on there to check pto, cooler and trans pressure . There is quick couplers on the ports but u can remove them in install a hyd hose to check pressure I believe it should be around 170 to 180
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
this would be behind the steps on tractor .do you know how to adjust press if it is low
thanks cat9944
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5
check press was ok . what would you might do next
 

·
Registered
Joined
·
520 Posts
Checked sender it may be slow to react to oil pressure. Leave gauge in and start unit and checked sender with a muiltmeter see if the resistance changes when oil pressure comes up.
 

·
Premium Member
Joined
·
5,233 Posts
check press was ok . what would you might do next
Analog gauges or Investigator II system? What tranny?

If it is Investigator, exactly which transmission light or lights are on, and what is the sequence? Have dealt with them more than once for various faults. Ways to test the system, but you need info from the Tests and Operation manual, the info is not in the service manuals. I can probably send you the necessary pages online possibly, or talk you thru it.

Had this issue with my 48 several years ago, mine ultimately was a issue with the logic sequence in the processor. I bypassed the sensors and rigged a gauge. Have never had another issue.
 

·
Registered
Joined
·
849 Posts
the pressure light comes on above 1200 rpm on the investigator, have had several that the sender checks out but replacing them solves the issue.
 
1 - 8 of 8 Posts
Top