The Combine Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
3 Posts
it is a hairpiece that covers the dispenser, behind the shelling cylinder, there are eight, and they are put to avoid the wear of the main piece or the dispenser
 

·
Registered
Joined
·
664 Posts
Discussion Starter #6
The pictures correct, always called it an impeller west kit... think that reply was using a translator, as I’ve never heard it referred to as the dispenser.
Yeah i got it. I know the last thing i want to do is look at a forum and help people out that speak another language, so its even more appreciated that he went through the trouble.

Side note, i have really horrible luck buying used from dealers. Was a bad omen when it came in on the truck and the driver hands me some straw chopper knives and said they had fallen on his deck.
 

Attachments

·
Registered
Joined
·
664 Posts
Discussion Starter #8
That had to be left in the hopper while working on the “dispenser”, no way it went through the machine.
Fingers crossed. Diving into the grain tank (since that appears to be the best way in) to check out the impeller in the morning.
 

·
Registered
Joined
·
3,463 Posts
Ahhh, mystery parts! Gotta love 'em! Have come across a few parts over the years either in the grain tank or laying in the field, and wondering what they are and how they got there!
 

·
Premium Member
Joined
·
8,052 Posts
Fingers crossed. Diving into the grain tank (since that appears to be the best way in) to check out the impeller in the morning.
Watch your nuts! No ladder in there, although there is an aftermarket one available made here in Manitoba. If you look at front right corner of the hopper you will see an access door, that is the proper hopper entrance, although I have never heard of someone actually using it...:rolleyes:

https://www.thecombineforum.com/forums/12-claas-lexion/304938-lexion-grain-tank-steps.html
 

·
Premium Member
Joined
·
8,052 Posts
Looks like the wear strips are in pretty good shape, perhaps they were just changed and one of the take-offs just wasn't brought out of the hopper?
 

·
Registered
Joined
·
664 Posts
Discussion Starter #14
Looks like the wear strips are in pretty good shape, perhaps they were just changed and one of the take-offs just wasn't brought out of the hopper?
Yeah the dealer replaced them before selling. I didnt see any missing and the bent one seems more worn, so thats probably exactly what happened. I'm going to be calling the dealer because it sounds pretty bad on loading now but I'm sure I won't get anywhere with that.
 
1 - 16 of 16 Posts
Top